































































  
           
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "https://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="https://www.w3.org/1999/xhtml" xmlns:fb="https://www.facebook.com/2008/fbml" xml:lang="en" lang="en">

<head>
  
  <meta name="viewport" content="width=1000">

  
  <meta name="layout" content="Blog Post" />
  
    <meta name="oid" content="36544591" />
  
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <meta http-equiv="imagetoolbar" content="no" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />

  
  
  
  <link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=342a1721f258d9bcb9b469d56cec1427" />
  <link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=342a1721f258d9bcb9b469d56cec1427" />
  <link rel="stylesheet" type="text/css" href="/styles/components.css?cb=342a1721f258d9bcb9b469d56cec1427" />
  <link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=342a1721f258d9bcb9b469d56cec1427" />

  
  
    <script src="/foundation/fontawesome/js/brands.min.js" async></script>
    <script src="/foundation/fontawesome/js/solid.min.js" async></script>
    <script src="/foundation/fontawesome/js/regular.min.js" async></script>
    <script src="/foundation/fontawesome/js/fontawesome.min.js" async></script>
    <script src="/foundation/fontawesome/js/light.min.js" async></script>
    <script src="/foundation/fontawesome/js/duotone.min.js" async></script>
  

  <style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>

  
    <link rel="stylesheet" type="text/css" href="/foundation/grids/iapetus-10-zone.css" />
  

  <!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
  <!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
  <!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
  <!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->

  <link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />

  
  
    
    
      <link rel="alternate" type="application/rss+xml" title="Riverfront Times RSS: Whole Site" href="https://www.riverfronttimes.com/stlouis/Rss.xml" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Riverfront Times RSS: News Section" href="https://www.riverfronttimes.com/stlouis/Rss.xml?oid=2348800" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Riverfront Times RSS: News Blog" href="https://www.riverfronttimes.com/stlouis/Rss.xml?oid=2512888" />
      
    

    
    
      <link rel="alternate" type="application/rss+xml" title="Riverfront Times RSS: Comments on St. Louis City Joins Forces With Local Schools to Vaccinate Kids Against COVID-19" href="https://www.riverfronttimes.com/stlouis/Rss.xml?id=comments&amp;oid=36544591" />
    
  

  

  
    <script>window.__FBAPIv__ = 'v3.2'</script>
  

  
  
    <!--[if lte IE 8]>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
      <![endif]-->
      
      <script>
        if (!window.Promise) document.write('<scr'+'ipt src="https://cdnjs.cloudflare.com/ajax/libs/native-promise-only/0.8.1/npo.src.js"></scr'+'ipt>')
      </script>
    
    
    
    
    <script src="/foundation/scripts/common.js?cb=c289b985398816685d466a1cacf436be"></script>
  
    
    
    
    
    
    
    <script src="/foundation/scripts/desktop-bundle.js?cb=c289b985398816685d466a1cacf436be"></script>
  

  
  <link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
  <script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>

  
  
  

  
  <script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("https:\/\/www.riverfronttimes.com\/stlouis\/Profile", "https:\/\/posting.riverfronttimes.com\/stlouis\/MyProfile");
  </script>
  
  
  

  
  
    <meta name="google-signin-client_id" content="87938396824-n9je30of0amajur33q7mm972pi0k5oc8.apps.googleusercontent.com">
  

    
  

  
  
<!-- Quantcast Choice. Consent Manager Tag v2.0 (for TCF 2.0) -->
  <script type="text/javascript" async=true>
  (function() {
    var host = window.location.hostname;
    var element = document.createElement('script');
    var firstScript = document.getElementsByTagName('script')[0];
    var url = 'https://quantcast.mgr.consensu.org'
      .concat('/choice/', 'ECpz7gxYXdCG2', '/', host, '/choice.js')
    var uspTries = 0;
    var uspTriesLimit = 3;
    element.async = true;
    element.type = 'text/javascript';
    element.src = url;

    firstScript.parentNode.insertBefore(element, firstScript);

    function makeStub() {
      var TCF_LOCATOR_NAME = '__tcfapiLocator';
      var queue = [];
      var win = window;
      var cmpFrame;

      function addFrame() {
        var doc = win.document;
        var otherCMP = !!(win.frames[TCF_LOCATOR_NAME]);

        if (!otherCMP) {
          if (doc.body) {
            var iframe = doc.createElement('iframe');

            iframe.style.cssText = 'display:none';
            iframe.name = TCF_LOCATOR_NAME;
            doc.body.appendChild(iframe);
          } else {
            setTimeout(addFrame, 5);
          }
        }
        return !otherCMP;
      }

      function tcfAPIHandler() {
        var gdprApplies;
        var args = arguments;

        if (!args.length) {
          return queue;
        } else if (args[0] === 'setGdprApplies') {
          if (
            args.length > 3 &&
            args[2] === 2 &&
            typeof args[3] === 'boolean'
          ) {
            gdprApplies = args[3];
            if (typeof args[2] === 'function') {
              args[2]('set', true);
            }
          }
        } else if (args[0] === 'ping') {
          var retr = {
            gdprApplies: gdprApplies,
            cmpLoaded: false,
            cmpStatus: 'stub'
          };

          if (typeof args[2] === 'function') {
            args[2](retr);
          }
        } else {
          queue.push(args);
        }
      }

      function postMessageEventHandler(event) {
        var msgIsString = typeof event.data === 'string';
        var json = {};

        try {
          if (msgIsString) {
            json = JSON.parse(event.data);
          } else {
            json = event.data;
          }
        } catch (ignore) {}

        var payload = json.__tcfapiCall;

        if (payload) {
          window.__tcfapi(
            payload.command,
            payload.version,
            function(retValue, success) {
              var returnMsg = {
                __tcfapiReturn: {
                  returnValue: retValue,
                  success: success,
                  callId: payload.callId
                }
              };
              if (msgIsString) {
                returnMsg = JSON.stringify(returnMsg);
              }
              event.source.postMessage(returnMsg, '*');
            },
            payload.parameter
          );
        }
      }

      while (win) {
        try {
          if (win.frames[TCF_LOCATOR_NAME]) {
            cmpFrame = win;
            break;
          }
        } catch (ignore) {}

        if (win === window.top) {
          break;
        }
        win = win.parent;
      }
      if (!cmpFrame) {
        addFrame();
        win.__tcfapi = tcfAPIHandler;
        win.addEventListener('message', postMessageEventHandler, false);
      }
    };

    makeStub();

    var uspStubFunction = function() {
      var arg = arguments;
      if (typeof window.__uspapi !== uspStubFunction) {
        setTimeout(function() {
          if (typeof window.__uspapi !== 'undefined') {
            window.__uspapi.apply(window.__uspapi, arg);
          }
        }, 500);
      }
    };

    var checkIfUspIsReady = function() {
      uspTries++;
      if (window.__uspapi === uspStubFunction && uspTries < uspTriesLimit) {
        console.warn('USP is not accessible');
      } else {
        clearInterval(uspInterval);
      }
    };

    if (typeof window.__uspapi === 'undefined') {
      window.__uspapi = uspStubFunction;
      var uspInterval = setInterval(checkIfUspIsReady, 6000);
    }
  })();
  </script>
  <!-- End Quantcast Choice. Consent Manager Tag v2.0 (for TCF 2.0) -->
<!-- Quantcast Choice CCPA -->
  <style>
    .ccpaNotice {
      clear: both;
      border: 2px solid #D0D1D3;
      padding: 13px;
      font-size: 16px;
    }
  </style>
  <script>
  if (typeof window.__uspapi === 'function') {
    window.__uspapi('uspPing', 1, function(obj, status) {
      if (status && obj.mode.includes('USP') && obj.jurisdiction.includes(obj.location.toUpperCase())) {
        var message = document.createElement("p");
        message.setAttribute("class", "ccpaNotice");
        message.innerHTML = 'Our website uses technical, analytical, marketing, and preference cookies to provide the best experience for our readers and to give us information about how our site is used. You may request that your data not be shared with third parties here: ' 
          + `<a href="#" onclick="window.__uspapi('displayUspUi');"` 
          + '>Do Not Sell My Data</a>' 
          + '.';
        document.getElementById('gridFooter').append(message);
        window.__uspapi('setUspDftData', 1, function(obj, status) {
          if (!status) {
              console.log("Error: USP string not updated!")
          }
        });
     }
    });
  }
  </script>
  <!-- end Quantcast Choice CCPA -->



<meta name="google-site-verification" content="t27RxzckhbflL78fSWUcvc_CarJTRS3UpdhCJHd8pCI" />
<meta name='msvalidate.01' content='3443F17DFB93961891E95B1452B50579' />
<meta name='pocket-site-verification' content='b1bd6d10226d722c350fdb32758f53' />
<link href='https://plus.google.com/113763785405995504983' rel='publisher' />


<!--  Google Verification -->
<meta name="google-site-verification" content="yW0a7N25x35btonU2z_kSz5V6UlPpd8RdziyVGaAudk" />


<!-- Begin Google Fonts -->
<link href='https://fonts.googleapis.com/css?family=Lato:400,700|Titillium+Web:400,700|Montserrat:400,700' rel='stylesheet' type='text/css'>
<!-- End Google Fonts -->




<script type='text/javascript'>
            var googletag = googletag || {};
            googletag.cmd = googletag.cmd || [];
            (function() {
              var gads = document.createElement('script');
              gads.async = true;
              gads.type = 'text/javascript';
              var useSSL = 'https:' == document.location.protocol;
              gads.src = (useSSL ? 'https:' : 'http:') + '//securepubads.g.doubleclick.net/tag/js/gpt.js';
              var node = document.getElementsByTagName('script')[0];
              node.parentNode.insertBefore(gads, node);
            })();
          </script>
          <script type='text/javascript'>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</script>

<!-- Begin Google Analytics -->
  
    <script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

    //
    ga('create', 'UA-67359815-1', 'riverfronttimes.com');
    ga('set', 'anonymizeIp', true);
    ga('send', 'pageview', { 'dimension1': 'blogs', 'dimension2': 'news' });
    </script>
  
  <!-- End Google Analytics -->





<script>
  var Euclid = Euclid || {}
  Euclid.RiverFrontTimes = Euclid.RiverFrontTimes || {}
  Euclid.RiverFrontTimes.vertical = Euclid.RiverFrontTimes.vertical || 'news'
  </script>
<script>
  (function() {
  if(document.getElementById('commitchange-script')) return;
  var npo = 5488;
  var script = document.createElement('script');
  var first = document.getElementsByTagName('script')[0];
  script.setAttribute('data-npo-id', npo);
  script.id = 'commitchange-script';
  script.src = 'https://us.commitchange.com/js/donate-button.v2.js';
  first.parentNode.insertBefore(script, first);
  })();
  </script>
<script>(function(p,i,c,o){var n=new Event("pico-init");i[p]=i[p]||function(){(i[p].queue=i[p].queue||[]).push(arguments)},i.document.addEventListener("pico-init",function(e){var t=i.Pico.getInstance(e,{publisherId:o,picoInit:n},i);t.handleQueueItems(i[p].queue),i[p]=function(){return t.handleQueueItems([arguments])}},!1);var e=i.document.createElement("script"),t=i.document.getElementsByTagName("script")[0];e.async=1,e.src=c,e.onload=function(e){return i.Pico.getInstance(e,{publisherId:o,picoInit:n},i)},t.parentNode.insertBefore(e,t)})("pico",window,"https://widget.pico.tools/wrapper.min.js","2b684e17-eec8-472c-9378-e4bf7212af6a");</script>
<style>
:root {
 --pub-primary-color:#31639C;
 --pub-link-color:#31639C;
}
</style>
  
  
  
  
  


  
  
  


  
  <link rel="shortcut icon" href="/favicon.ico" />
  <meta name="title" content="St. Louis City Joins Forces With Local Schools to Vaccinate Kids Against COVID-19 | News Blog" />
  <meta name="description" content="Now that the FDA has approved the Pfizer COVID-19 vaccine for kids ages five to eleven, the next step is actually getting your child vaccinated...." />
  <meta name="keywords" content="St. Louis news, St. Louis, Missouri, pediatric covid vaccine, COVID-19 vaccine, where to get kids covid vaccine, St. Louis Public Schools" />
  <title>St. Louis City Joins Forces With Local Schools to Vaccinate Kids Against COVID-19 | News Blog</title>

  
  
    <meta name="date" content="2021-11-04 15:21:00" />
  

  
  
  
    <meta name="author" content="Jenna Jones">
  

  
  
  <meta name="news_keywords" content="st louis news, st louis, missouri, pediatric covid vaccine, covid19 vaccine, where to get kids covid vaccine, st louis public schools" />

  
  

  
  
    
  
  
    <link rel="image_src" href="https://media1.fdncms.com/riverfronttimes/imager/u/slideshow/36544835/mayorjonespressconf.jpg" />
    <meta name="thumbnail" content="https://media1.fdncms.com/riverfronttimes/imager/u/slideshow/36544835/mayorjonespressconf.jpg" />
  

  
    
      <link rel="canonical" href="https://www.riverfronttimes.com/newsblog/2021/11/04/st-louis-city-joins-forces-with-local-schools-to-vaccinate-kids-against-covid-19" />
      <link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.riverfronttimes.com/newsblog/2021/11/04/st-louis-city-joins-forces-with-local-schools-to-vaccinate-kids-against-covid-19" />
    

    
    
    
      
      
      <link rel="amphtml" href="https://www.riverfronttimes.com/newsblog/2021/11/04/st-louis-city-joins-forces-with-local-schools-to-vaccinate-kids-against-covid-19?media=AMP+HTML" />
    
  

  
    
      <meta property="og:url" content="https://www.riverfronttimes.com/newsblog/2021/11/04/st-louis-city-joins-forces-with-local-schools-to-vaccinate-kids-against-covid-19" />
    
  

  
    <meta property="fb:app_id" content="1429692410383325" />
  

  
  <meta property="og:site_name" content="Riverfront Times" />
  <meta property="og:title" content="St. Louis City Joins Forces With Local Schools to Vaccinate Kids Against COVID-19" />

   
  
    

    
    

    
    

    <meta property="og:image" content="https://media1.fdncms.com/riverfronttimes/imager/u/slideshow/36544835/mayorjonespressconf.jpg" />

    
      <meta property="og:image:width" content="600" />
      <meta property="og:image:height" content="337" />
    
  

  
  
    <meta property="og:description" content="Now that the FDA has approved the Pfizer COVID-19 vaccine for kids ages five to eleven, the next step is actually getting your child vaccinated...." />
  

  
  

  
  
    <meta property="og:type" content="article" />
  

  
  

    
    

    
    
    

    
      <meta name="twitter:card" content="summary_large_image">
      <meta name="twitter:image" content="https://media1.fdncms.com/riverfronttimes/imager/u/slideshow/36544835/mayorjonespressconf.jpg">

    
    

    
      <meta name="twitter:creator" content="@writesjenna">
    

    <meta name="twitter:site" content="@riverfronttimes/">
    <meta name="twitter:title" content="St. Louis City Joins Forces With Local Schools to Vaccinate Kids Against COVID-19">
    <meta name="twitter:description" content="Now that the FDA has approved the Pfizer COVID-19 vaccine for kids ages five to eleven, the next step is actually getting your child vaccinated....">
  

  
  
  <!--
    <PageMap>
      <DataObject type="foundation">
        <Attribute name="oid">36544591</Attribute>
        <Attribute name="class">Content</Attribute>
        <Attribute name="lastmodified">20211104152152</Attribute>
        <Attribute name="creationdate">20211104134658</Attribute>
      </DataObject>

      
        
          <DataObject type="document">
            <Attribute name="releasedatetime">20211104152100</Attribute>
            <Attribute name="releasedate">20211104</Attribute>
            <Attribute name="releaseepoch">1636057260</Attribute>
            <Attribute name="title">St. Louis City Joins Forces With Local Schools to Vaccinate Kids Against COVID-19</Attribute>
            <Attribute name="author">32960426</Attribute>
            <Attribute name="authorname">Jenna Jones</Attribute>
            <Attribute name="authorsortname">Jones, Jenna</Attribute>
          </DataObject>
        

        
      
    </PageMap>
  -->


  
  
  
  
    
    <script type="application/ld+json">
        {
          "mainEntityOfPage": {
            "@type": "WebPage",
            "@id":"https:\/\/www.riverfronttimes.com\/newsblog\/2021\/11\/04\/st-louis-city-joins-forces-with-local-schools-to-vaccinate-kids-against-covid-19"
          },
          "headline": "St. Louis City Joins Forces With Local Schools to Vaccinate Kids Against COVID-19",
          
            "description": "Now that the FDA has approved the Pfizer COVID-19 vaccine for kids ages five to eleven, the next step is actually getting your child vaccinated. Walgreens began accepting appointments yesterday, while St. Louis County will be able to vaccinate children at county library branches next week; meanwhile, St. Louis city unveiled its plan today.",
          
          
            "image": {
              "url": "https:\/\/media1.fdncms.com\/riverfronttimes\/imager\/u\/original\/36544835\/mayorjonespressconf.jpg",
              "width": 884,
              "height": 497,
              "@type": "ImageObject"
            },
          
          "datePublished": "2021-11-04T15:21:00",
          "dateModified": "2021-11-04T15:21:52",
          
            "author": {
              "name": "Jenna Jones",
              "@type": "Person"
            },
          
          "publisher": {
            "name": "Riverfront Times",
            
              
              
              
              "logo": {
                "url": "https:\/\/www.riverfronttimes.com\/imager\/b\/google-amp-logo\/808579\/2a75\/riverfront_fb.png",
                "width": 60,
                "height": 60,
                "@type": "ImageObject"
              },
            
            "@type": "Organization"
          },
          "@context": "https://schema.org",
          "@type": "NewsArticle"
        }
      </script>
  


</head>





  <body id="Post" class="BlogPost Iapetus10Zone news newsblog">




<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-W5SPSS"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-W5SPSS');</script>
<!-- End Google Tag Manager -->

<div id="fb-root"></div>


  <script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>




  <script>
    (function () {
      var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
        //if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
      }.bind(this), function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
      })
    })()
  </script>
    

<!-- Leader -->
<div id="gridLeader">
  <div id="AdInterstitial" class="Leader BlogPost ">
  <!-- /43707298/STL_DesktopInterstitial -->
          <div id="div-gpt-ad-stl_desktopinterstitial" style="" data-content-type="ad" data-slot="/43707298/STL_DesktopInterstitial" data-output="asynchronous" data-width="" data-height="">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-stl_desktopinterstitial');
                });
              </script>
          </div>
</div>
      <style>
      /*-- desktop styles --*/
       #AdBackground {top:50px!important;}
      .nominate-bar {
          background:#91114f;
          z-index: 1;
          overflow:hidden;
          width: 100%;
          padding: 0;
          text-transform: uppercase;
          text-align: center;
          color: #fff;
          font-size: 18px;
      }
      .nominate-bar div {
      	border: 1px solid #ffffff;
          margin: 5px auto;
          max-width: 1000px;
      }
      .nominate-bar a {
      	color:#fff;
      }
  /* Adjust the ad positioning */
  body {
    background-position-y: 39px !important;
  }

      </style>
  

  <div class="nominate-bar">
  	<div>
      <p><a href="https://www.riverfronttimes.com/stlouis/SupportLocalJournalism/Page" target="_new">Support Local Journalism. Join Riverfront Times Press Club.</a></p>
      </div>
  </div>
</div><!-- end gridLeader -->

<div id="gridClamp">
  <!-- Header -->
  <div id="gridHeader">
    




  
  

  
  
  

  

    
      <div id="MobileDetect" class="GlobalHeader BlogPost " style="display:none">
        
        
          Switch to the <a href="https://m.riverfronttimes.com/newsblog/2021/11/04/st-louis-city-joins-forces-with-local-schools-to-vaccinate-kids-against-covid-19" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
        
      </div>
    

    <script>
      
      function setRedirectHash() {
        if (location.hash) {
          jQuery("#MobileDetect a[media='handheld']").each(function() {
            var link = jQuery(this);
            link.attr('href', link.attr('href').split('#')[0] + location.hash);
          });
        }
      }
      setRedirectHash();

      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
  











<div id="LogoHeader" class="GlobalHeader BlogPost ">
  
    
    <div id="logoLeft">      
      <a href="https://www.riverfronttimes.com/" title="St. Louis Riverfront Times">St. Louis Riverfront Times</a>
    </div>

    <div id="leaderboardAdHeader">
      <!-- /43707298/STL_728x90 -->
          <div id="div-gpt-ad-stl_728x90-1" style="" data-content-type="ad" data-slot="/43707298/STL_728x90" data-output="asynchronous" data-width="728" data-height="90">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-stl_728x90-1');
                });
              </script>
          </div>
    </div>
      
      
</div>
<!-- End #LogoHeader -->















  <div id="NavigationHorizontal" class="GlobalHeader BlogPost  ">
    
      
      
          <ul id="mainNav">
        
        

        

        

        

        <li class="first navCurrent" id="NavItem_News">
          <a href="https://www.riverfronttimes.com/stlouis/news/Section?oid=2348800"  class="subnav_link" id="SNAVL_News">News</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_ArtsCulture">
          <a href="https://www.riverfronttimes.com/stlouis/arts-and-culture/Section?oid=2348805"  >Arts &amp; Culture</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Dining">
          <a href="https://www.riverfronttimes.com/stlouis/dining/Section?oid=2348803"  class="subnav_link" id="SNAVL_Dining">Dining</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Music">
          <a href="https://www.riverfronttimes.com/stlouis/music/Section?oid=2348804"  >Music</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Film">
          <a href="https://www.riverfronttimes.com/stlouis/movies/Section?oid=2348802"  class="subnav_link" id="SNAVL_Film">Movies</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_ReeferfrontTimes">
          <a href="https://www.riverfronttimes.com/stlouis/reeferfront-times/Section?oid=35262379"  class="subnav_link" id="SNAVL_ReeferfrontTimes">Reeferfront Times</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Calendar">
          <a href="https://www.riverfronttimes.com/stlouis/EventSearch"  class="subnav_link" id="SNAVL_Calendar">Calendar</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_bestof">
          <a href="https://www.riverfronttimes.com/stlouis/BestOf"  class="subnav_link" id="SNAVL_bestof">Best Of</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Slideshows">
          <a href="http://photos.riverfronttimes.com"  >Slideshows</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Support">
          <a href="https://www.riverfronttimes.com/stlouis/SupportLocalJournalism/Page"  class="subnav_link" id="SNAVL_Support">Support</a>
        </li>
        
      
        

        

        

        

        <li class="last" id="NavItem_Advertise">
          <a href="https://www.riverfronttimes.com/stlouis/AdvertiseWithRiverfrontTimes/Page"  >Advertise</a>
        </li>
        
      
          </ul>
        

      
        
        
          
            <h3 class="hidden">Browse News</h3>
            <ul class="subnav_content" id="SNAV_News" style="display:none;">
          

          

          <li class="">
            <a href="https://www.riverfronttimes.com/stlouis/ArticleArchives?tag=Election%202020"  title="">Election Coverage</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.riverfronttimes.com/stlouis/ArticleArchives?tag=coronavirus"  title="">Coronavirus Updates</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.riverfronttimes.com/stlouis/special-issues/Section?oid=2348807"  title="">Special Issues</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.riverfronttimes.com/stlouis/IssueArchives?issue=thisweek" target="_blank" title="">Digital Issue</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.riverfronttimes.com/stlouis/joblistings/Page"  title="">Local Job Listings</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Dining</h3>
            <ul class="subnav_content" id="SNAV_Dining" style="display:none;">
          

          

          <li class="">
            <a href="https://www.riverfronttimes.com/stlouis/GoodTo-GoStLouisADirectoryofLocalBusinessesYouCanSupportDuringtheCoronavirusEra/Page"  title="">Good To-Go St. Louis</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Movies</h3>
            <ul class="subnav_content" id="SNAV_Film" style="display:none;">
          

          

          <li class="">
            <a href="https://www.riverfronttimes.com/stlouis/movies/Section?oid=2348802"  title="">Movie Reviews and News</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.riverfronttimes.com/stlouis/MovieTimes"  title="">Movie Times</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.riverfronttimes.com/stlouis/LocationSearch?locationCategory=2683256&sortType=name"  title="">Find a Theater</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.riverfronttimes.com/stlouis/FreeStuff"  title="">Giveaways</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Calendar</h3>
            <ul class="subnav_content" id="SNAV_Calendar" style="display:none;">
          

          

          <li class="">
            <a href="https://www.riverfronttimes.com/stlouis/EventSearch?narrowByDate=Today"  title="">Today&#39;s Events</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.riverfronttimes.com/stlouis/EventSearch?narrowByDate=This%20Weekend"  title="">This Weekend</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.riverfronttimes.com/stlouis/Events/AddEvent"  title="">Submit an Event</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Special Issues</h3>
            <ul class="subnav_content" id="SNAV_SpecialIssues" style="display:none;">
          

          

          <li class="">
            <a href="https://www.riverfronttimes.com/stlouis/BestOf"  title="">Best Of St. Louis</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.riverfronttimes.com/stlouis/city-guide/Category?oid=3138571"  title="">City Guide</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.riverfronttimes.com/stlouis/summer-guide/Category?oid=2349249"  title="">Summer Guide</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Support</h3>
            <ul class="subnav_content" id="SNAV_Support" style="display:none;">
          

          

          <li class="">
            <a href="https://shop.euclidmediagroup.com/collections/riverfront-times" target="_blank" title="">Shop RFT</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.riverfronttimes.com/stlouis/SupportLocalJournalism/Page"  title="">Donate</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.riverfronttimes.com/stlouis/Newsletters/Page"  title="">Subscribe</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.facebook.com/riverfronttimes" target="_blank" title="">Riverfront Times Facebook</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://twitter.com/riverfronttimes/" target="_blank" title="">Riverfront Times Twitter</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://instagram.com/riverfronttimes/" target="_blank" title="">Riverfront Times Instagram</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Best Of</h3>
            <ul class="subnav_content" id="SNAV_bestof" style="display:none;">
          

          

          <li class="">
            <a href="https://vote.riverfronttimes.com/" target="_blank" title="">2021 Readers Poll</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Reeferfront Times</h3>
            <ul class="subnav_content" id="SNAV_ReeferfrontTimes" style="display:none;">
          

          

          <li class="">
            <a href="https://www.riverfronttimes.com/stlouis/dispensary-reviews/Category?oid=35262629"  title="">Dispensary Reviews</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.riverfronttimes.com/blogs/WeedNews/"  title="">Weed News</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.riverfronttimes.com/stlouis/LocationSearch?locationSection=35262377&sortType=name"  title="">Dispensary Directory</a>
          </li>
          
            </ul>
          
        

        

        
        
        
      
    
  </div>


  

  
  
  
    
    

      

      <script>
      "use strict";
      (function(){
        //
        if(navigator.userAgent.match(/\b(iPad|iPhone|iPod|Android|Pre|BlackBerry|Windows Phone)\b/i)){
          //
          //
            jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
          //
          //

        //
        }else{
          jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
        }
      })();
      </script>
    
  
  <!-- true == "true"
         && true == "devel" -->


<!-- End #NavigationHorizontal --><div id="AdPencilBar" class="GlobalHeader BlogPost ">
  <!-- /43707298/STL_970x90 -->
          <div id="div-gpt-ad-stl_970x90" style="" data-content-type="ad" data-slot="/43707298/STL_970x90" data-output="asynchronous" data-width="970" data-height="90">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-stl_970x90');
                });
              </script>
          </div>
</div>
  </div><!-- end gridHeader -->

  <div id="gridMain">

    <div id="gridFrame">

      <div id="gridSpanningFeature">
        



  
  
  

  <!-- UIkit CSS -->
  <link rel="stylesheet" type="text/css" href="/fdn-system/assets/pub/styles/desktop.css?cb=67b275f93a114745cde46f8785ece2b5" />

  <!-- UIkit JS -->
  <script src="/fdn-system/assets/pub/scripts/uikit.min.js?cb=67b275f93a114745cde46f8785ece2b5"></script>
  <script src="/fdn-system/assets/pub/scripts/uikit-icons-fdn.min.js?cb=67b275f93a114745cde46f8785ece2b5"></script>


  

  <style>
    @media (min-width: 640px){
      div[id] .uk-child-width-1-3\@exs > * {
         width: calc(100% * 1 / 3.001);
      } 
    }
    #gridMainColumn .uk-width-1-2\@es {
      width: 50%;
    }

    #gridMainColumn .uk-child-width-auto\@exs > * {
      width: auto;
    }
    
    .uk-root {
      font-size: 14px;
    }
  </style>













  
  















  
  
  

  
  
  

  
 
  




  

  
    
    
  

  
  <style>
    div.l0.last div:first-child {float:right;}
  </style>
  
  <div id="ToolBarHorizontal" class="SpanningFeature BlogPost ">
    <div style="width:100%; height: 20px;">
      <div class="l0 first" style="width:20%; height: 20px; float:left;">
        <fb:like href="https://www.riverfronttimes.com/newsblog/2021/11/04/st-louis-city-joins-forces-with-local-schools-to-vaccinate-kids-against-covid-19" send="false" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="button_count"></fb:like></div> <div class="l0" style="width:20%; height: 20px; float:left;"><a href="https://twitter.com/share?url=https%3A//www.riverfronttimes.com/newsblog/2021/11/04/st-louis-city-joins-forces-with-local-schools-to-vaccinate-kids-against-covid-19&text=St.%20Louis%20City%20Joins%20Forces%20With%20Local%20Schools%20to%20Vaccinate%20Kids%20Against%20COVID-19" class="twitter-share-button" data-count="none">Tweet</a>
<script>
  dnLoadScript("https://platform.twitter.com/widgets.js", true);
</script></div> <div class="l0" style="width:20%; height: 20px; float:left;">

<a class="emailAction" title="Email" href="https://posting.riverfronttimes.com/stlouis/Tools/EmailFriend?oid=36544591" rel="nofollow" target="_blank" onclick="popupWindow('popupEmailFriend', this.href, 400, 650, 400, 10); return false">Email</a>

</div> <div class="l0" style="width:20%; height: 20px; float:left;">

<a class="printAction" title="Print" href="https://www.riverfronttimes.com/newsblog/2021/11/04/st-louis-city-joins-forces-with-local-schools-to-vaccinate-kids-against-covid-19?mode=print" rel="nofollow" target="_blank">Print</a>
</div> <div class="l0 last" style="width:20%; height: 20px; float:right;">




  <div class="addthis_toolbox addthis_default_style"><a href="https://www.addthis.com/bookmark.php?v=300&pubid=ra-55a583d7ad700c31" addthis:url="https://www.riverfronttimes.com/newsblog/2021/11/04/st-louis-city-joins-forces-with-local-schools-to-vaccinate-kids-against-covid-19" addthis:title="St. Louis City Joins Forces With Local Schools to Vaccinate Kids Against COVID-19" addthis:description="" class="addthis_button_compact">Share</a></div>
  <script type="text/javascript">
    dnLoadScript("https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-55a583d7ad700c31", true);
  </script>


      </div>
    </div>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  

















  
  <link type="text/css" href="/foundation/scripts/jplayer/skin/jplayer.blue.monday.css" rel="stylesheet" />
  <script type="text/javascript" src="/foundation/scripts/jplayer/jquery.jplayer.min.js"></script>               
  
    <style>
    div.jp-audio,
    div.jp-video {
      /* Edit the font-size to counteract inherited font sizing.
       * Eg. 1.25em = 1 / 0.8em
       */
      font-size:1.25em;
    }      
    div.postBody div.inlineAudio,
    div#AudioPlayer div.inlineAudio {
      width: 400px;
      margin: auto;
      clear:both;
      }      
    </style>
  


  <div id="BlogsBlogPost" class="SpanningFeature BlogPost   ">

    

    









































    

    
    

    
      
      
        <h2 class="blogDate">Thursday, November  4, 2021</h2>
      

      
      <div class="blogPost newsblog ">
    
    
        
    
    
    <h1 class="postTitle" id="a36544591">
      
      
      
      
      
      
        St. Louis City Joins Forces With Local Schools to Vaccinate Kids Against COVID-19
      

      
    </h1>

    

    
      <h4 class="postedBy">
        

        
          <span class="byAttribute">Posted</span>
        
        
        
          
          <span class="byAttribute">By</span> <a href="https://www.riverfronttimes.com/author/jenna-jones" rel="author">Jenna Jones</a>
        
        
          
            on <span class="postTime">Thu, Nov  4, 2021</span> at <span class="postTime"> 3:21 PM</span>
          
        
           
      </h4>
    

   
    
    

    

    
    

    
    

    <div class="postBody">
      
          
      


      
     
       
      

        

        

        

        

        

        

        
        

        

        

        
      
      
      
      
       
      
      

      
      

      
      
        
        <div class="contentImageCenter" style="overflow:hidden;">                                              <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/riverfronttimes/imager/u/original/36544835/mayorjonespressconf.jpg" class="zoomable" rel="contentImg_gal-36544591" title="Mayor Tishaura Jones announces the city of St. Louis&#39; plans to get kids vaccinated against COVID-19. - SCREENGRAB FROM MAYOR TISHAURA JONES / FACEBOOK LIVE">                  <img src="https://media1.fdncms.com/riverfronttimes/imager/u/blog/36544835/mayorjonespressconf.jpg?cb=1636056665" width="600" height="337" alt="Mayor Tishaura Jones announces the city of St. Louis&#39; plans to get kids vaccinated against COVID-19. - SCREENGRAB FROM MAYOR TISHAURA JONES / FACEBOOK LIVE" srcset="" />                </a>                                                                                                           <ul style="width:600px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                          <li class="imageCredit">                                              Screengrab from <a href="https://www.facebook.com/MayorTishauraJones/videos/273933007993432" target="_blank">Mayor Tishaura Jones / Facebook Live </a>                                          </li>                                                                                                                            <li class="imageCaption">                      Mayor Tishaura Jones announces the city of St. Louis' plans to get kids vaccinated against COVID-19.                    </li>                                                                                                </ul>                                                       </div><br>
  Now that the FDA has approved the Pfizer COVID-19 vaccine for kids ages five to eleven, the next step is actually getting your child vaccinated. <a href="/newsblog/2021/11/03/children-can-get-their-covid-19-vaccine-at-walgreens-beginning-saturday" target="_blank">Walgreens began accepting appointments yesterday</a>, while <a href="/newsblog/2021/11/01/st-louis-county-executive-unveils-plan-for-vaccinating-children-against-covid-19" target="_blank">St. Louis County will be able to vaccinate children</a> at county library branches <a href="https://www.facebook.com/photo?fbid=261309372700612&amp;set=a.233343538830529" target="_blank">next week</a>; meanwhile, St. Louis city unveiled its plan today.

            
          
            <br>
  <br>
   Accompanied today by St. Louis Public Schools superintendent Kelvin Adams and the City of Saint Louis Department of Health director Dr. Mati Hlatshwayo Davis, Mayor Tishaura Jones urged parents to get their children vaccinated. The city will be partnering with local schools and healthcare centers to provide the COVID-19 vaccine to the newly eligible age group.

            

              
              
                <br><br>
              

              <div class="inlineComponent AdNativeInline">
                <div id="AdNativeInline" class="SpanningFeature AdNativeInline ">
  <!-- /43707298/STL_DesktopNative -->
          <div id="div-gpt-ad-stl_desktopnative-2" style="" data-content-type="ad" data-slot="/43707298/STL_DesktopNative" data-output="asynchronous" data-width="" data-height="">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-stl_desktopnative-2');
                });
              </script>
          </div>
</div>
              </div>
            
          
            <br>
  <br>
   “Pediatric vaccination is the key to protecting our children, protecting our schools, and protecting our communities,”  Jones said in a press release. “I made sure my son was vaccinated to make sure he can keep learning in-person and do the things he loves. Getting our kids vaccinated helps us keep our schools open, safe, and healthy while protecting families this holiday season.”

            
          
            <br>
  <br>
   Locations the city has partnered with to get your child vaccinated include The Regional Health Commission, Affinia, CARESTL, BJC, Glennon and SSM, all of which have multiple locations. The city also has a partnership with St. Louis Public Schools; two vaccination clinics will be held at <b>Gateway Middle School</b> <i>(1200 North Jefferson Avenue)</i> on November 13 and on December 4 from 9 a.m. to 12 p.m. Older children and city residents can also get vaccinated here, with residents receiving a $100 gift card after their first dose.

            
          
            <br>
  <br>
   “We must host children where they are most comfortable: schools, their primary care physicians or healthcare systems and the community groups that have earned their trust,” Dr. Hlatshwayo Davis said in a statement. 

            
          
            <br>
  <br>
Davis added in the press release that the city must be “considerate of times outside of school and work: after hours and weekends,” which their plan directly addresses. Adams said in a statement that vaccination is the “best path to some semblance of normalcy,” and he encourages anyone with an eligible child to get vaccinated.

            
          
            <br>
  <br>
   More clinics and partnerships are planned, so residents are encouraged to keep an eye on the department of health’s <a href="https://www.stlouis-mo.gov/government/departments/health/communicable-disease/covid-19/vaccine/pediatrics.cfm" target="_blank">website</a>.<br>
 <i><br>
           Follow Jenna on Twitter at <a href="https://twitter.com/writesjenna" target="_blank">@writesjenna</a>. Email the author at jenna@riverfronttimes.com</i>                 
<ul>
                                                                                                                                         
  <li><a href="https://www.riverfronttimes.com/stlouis/Newsletters/Page/">Sign up</a> for our weekly newsletters to get the latest on the news, things to do and places to eat delivered right to your inbox.</li>
                                                                           
  <li>Follow us on <a href="https://www.facebook.com/riverfronttimes">Facebook</a>, <a href="https://twitter.com/riverfronttimes/">Twitter</a> and <a href="https://www.instagram.com/riverfronttimes/">Instagram</a>.</li>
                                                        
</ul>
      
      
      <div class="clearfix"></div>
      
      
      
    </div>

    
    
    
      
    

    

    
      
      <p class="tags">
        Tags: <a href="https://www.riverfronttimes.com/stlouis/ArticleArchives?tag=St.%20Louis%20news" rel="tag">St. Louis news</a>, <a href="https://www.riverfronttimes.com/stlouis/ArticleArchives?tag=St.%20Louis" rel="tag">St. Louis</a>, <a href="https://www.riverfronttimes.com/stlouis/ArticleArchives?tag=Missouri" rel="tag">Missouri</a>, <a href="https://www.riverfronttimes.com/stlouis/ArticleArchives?tag=pediatric%20covid%20vaccine" rel="tag">pediatric covid vaccine</a>, <a href="https://www.riverfronttimes.com/stlouis/ArticleArchives?tag=COVID-19%20vaccine" rel="tag">COVID-19 vaccine</a>, <a href="https://www.riverfronttimes.com/stlouis/ArticleArchives?tag=where%20to%20get%20kids%20covid%20vaccine" rel="tag">where to get kids covid vaccine</a>, <a href="https://www.riverfronttimes.com/stlouis/ArticleArchives?tag=St.%20Louis%20Public%20Schools" rel="tag">St. Louis Public Schools</a>, <a href="https://www.riverfronttimes.com/stlouis/ArticleArchives?contentFeature=2124603" rel="tag">Image</a>
      </p>
    

    

  </div> <!-- end blogPost -->
    
    <div class="clear"></div>
  </div>









































<div id="CommitChangeWidget" 
     class="SpanningFeature BlogPost " 
     style="background-color: rgba(250, 250, 153, 1); padding: 10px;">

<center><p><big><b>Support Local Journalism.</b></big><br>
<big><b>Join the <i>Riverfront Times</i> Press Club</b></big><br><br>

Local journalism is information. Information is power. And we believe <b>everyone</b> deserves access to accurate independent coverage of their community and state. Our readers helped us continue this coverage in 2020, and we are so grateful for the support.
<br><br>

Help us keep this coverage going in 2021. Whether it's a one-time acknowledgement of this article or an ongoing membership pledge, your support goes to local-based reporting from our small but mighty team.
<br><br>

<big><b><a href="https://trypico.com/riverfronttimes?short_code=vjzgr2zk">Join the Riverfront Times Club for as little as $5 a month.</a>
</b></big>
  
</center>

</div><div id="JumptoComments" class="SpanningFeature BlogPost ">
  <a href="#Disqus">Jump to comments</a>
</div><!-- End JumptoComments -->


  
  

  <div id="BlogsPreviousNext" class="SpanningFeature BlogPost ">
    <div class="prevNext">
      
        <a href="https://www.riverfronttimes.com/newsblog/2021/11/04/from-ferguson-to-st-louis-twelve-miles-and-seven-years" class="prev" rel="prev">&laquo;&nbsp;From Ferguson to St. Louis: Twelve&hellip;</a>
        
    </div>
  </div>





  <div id="ArchiveLink" class="SpanningFeature BlogPost ">
    <p class="moreArticles">
      
        <a href="https://www.riverfronttimes.com/stlouis/ArticleArchives?category=2512888">More News Blog &raquo;</a>
      
      
    </p>
  </div> <!-- end ArchiveLink -->




  

  
    <div class="uk-root">
  

  





<div class="componentGrid-TwoZones-Auto-Expand uk-root uk-width-1-1 uk-flex uk-flex-row uk-flex-wrap fdn-component-grid-row@m" uk-height-match data-component-grid-id="TopStoriesVideoPair">

  <div class="uk-width-1-1 uk-width-auto@m uk-flex uk-flex-column uk-inline fdn-component-grid-zone">
    

















<div class="ComponentZoneA TopStoriesVideoPairresponsive  trending-by-day uk-root fdn-margin-vert TrendingContentList comp-landing-trending" data-component-id="TrendingContentList">
  <div class="fdn-component-header-block uk-margin ">

      

      <h3 class="fdn-component-header-text uk-margin-remove ">
        
          Trending
        
      </h3>

      

      
    </div>

    
    
    

    
        <ul class="pres-ContentListHeadline uk-list uk-list-divider">
      
      

      <li class="fdn-pres-item">
    <a class="uk-flex uk-flex-top" href="https://www.riverfronttimes.com/stlouis/coming-out-in-1994-nearly-cost-rodney-wilson-his-teaching-job-has-missouri-learned-anything/Content?oid=36536936">
      <p class="fdn-teaser-headline">
        Coming Out in 1994 Nearly Cost Rodney Wilson His Teaching Job. Has Missouri Learned Anything?
      </p>
    </a>
  </li>

      
   
    
      

      <li class="fdn-pres-item">
    <a class="uk-flex uk-flex-top" href="https://www.riverfronttimes.com/stlouis/in-the-rush-to-build-the-next-napa-valley-what-happens-to-augusta/Content?oid=36495441">
      <p class="fdn-teaser-headline">
        In the Rush to Build the Next Napa Valley, What Happens to Augusta?
      </p>
    </a>
  </li>

      
   
    
      

      <li class="fdn-pres-item">
    <a class="uk-flex uk-flex-top" href="https://www.riverfronttimes.com/newsblog/2021/11/03/rev-darryl-gray-wins-right-to-jury-trial-in-4-year-old-police-abuse-case">
      <p class="fdn-teaser-headline">
        Rev. Darryl Gray Wins Right to Jury Trial in 4-Year-Old Police Abuse Case
      </p>
    </a>
  </li>

      
   
    
        </ul>
      

  

</div>

    
  </div>

  <div class="uk-width-1-1 uk-width-expand@m uk-flex uk-flex-column uk-inline fdn-component-grid-zone">
    

<!-- riverfronttimes -->
<script src="https://www.voqally.com/hub/app/r.js?key=16fa797df65f83d4a5d14d36954afeff" defer="defer"></script>
    
  </div>

</div>


  
    </div>
  












  
  

  
  



    
    
    
    
























  
      <div id="RelatedStories" class="SpanningFeature BlogPost RelatedItem">
        <h3><span class="headingText">Related Stories</span></h3>
        <ul class="">
    
    

    <li class="l0 storyItem">
    
      
      <a href="https://www.riverfronttimes.com/newsblog/2021/11/03/children-can-get-their-covid-19-vaccine-at-walgreens-beginning-saturday?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RelatedStories">
        <img src="https://media2.fdncms.com/riverfronttimes/imager/u/bigsquare/36537847/26362814195_70549b360d_c.jpg"
             alt="Children Can Get Their COVID-19 Vaccine at Walgreens Beginning Saturday"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/newsblog/2021/11/03/children-can-get-their-covid-19-vaccine-at-walgreens-beginning-saturday?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RelatedStories">Children Can Get Their COVID-19 Vaccine at Walgreens Beginning Saturday</a>
    </h4>
    <div class="date"> Nov  3, 2021 </div>
  </li> 

    
  
    

    <li class="l0 storyItem">
    
      
      <a href="https://www.riverfronttimes.com/newsblog/2021/11/01/st-louis-county-executive-unveils-plan-for-vaccinating-children-against-covid-19?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RelatedStories">
        <img src="https://media2.fdncms.com/riverfronttimes/imager/u/bigsquare/36525759/sampage111.jpg"
             alt="St. Louis County Executive Unveils Plan for Vaccinating Children Against COVID-19"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/newsblog/2021/11/01/st-louis-county-executive-unveils-plan-for-vaccinating-children-against-covid-19?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RelatedStories">St. Louis County Executive Unveils Plan for Vaccinating Children Against COVID-19</a>
    </h4>
    <div class="date"> Nov  1, 2021 </div>
  </li> 

    
  
    

    <li class="l0 storyItem">
    
      
      <a href="https://www.riverfronttimes.com/newsblog/2021/09/22/st-louis-county-introduces-covid-19-vaccine-gift-card-incentive-program?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RelatedStories">
        <img src="https://media2.fdncms.com/riverfronttimes/imager/u/bigsquare/36299823/preview.jpg"
             alt="St. Louis County Introduces COVID-19 Vaccine Gift Card Incentive Program"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/newsblog/2021/09/22/st-louis-county-introduces-covid-19-vaccine-gift-card-incentive-program?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RelatedStories">St. Louis County Introduces COVID-19 Vaccine Gift Card Incentive Program</a>
    </h4>
    <div class="date"> Sep 22, 2021 </div>
  </li> 

    
  
        </ul>
      </div>
    

<div id="AdNativeEndofArticle" class="SpanningFeature BlogPost ">
  <!-- /43707298/STL_DesktopNative -->
          <div id="div-gpt-ad-stl_desktopnative-3" style="" data-content-type="ad" data-slot="/43707298/STL_DesktopNative" data-output="asynchronous" data-width="" data-height="">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-stl_desktopnative-3');
                });
              </script>
          </div>
</div>
  



















  

  























  
      <div id="RecentByTag" class="SpanningFeature BlogPost ">
        <h3 class="latestfood_blog">
          <span class="headingText">
          
            Speaking of...
          
          </span>
        </h3>
        
        <ul class="moduleList">

        
        
        
    
    

    
    

    

    
      <li class="l0 storyItem">
    
      
      <a href="https://www.riverfronttimes.com/foodblog/2021/11/05/st-louis-standards-oconnells-is-the-house-that-jack-built?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RecentByTag">
        <img src="https://media2.fdncms.com/riverfronttimes/imager/u/bigsquare/36539028/oconnels_preview.jpg"
             alt="St. Louis Standards: O&#39;Connell&#39;s Is the House that Jack Built"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/foodblog/2021/11/05/st-louis-standards-oconnells-is-the-house-that-jack-built?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RecentByTag">St. Louis Standards: O'Connell's Is the House that Jack Built</a>
    </h4>
    <div class="date"> Nov  5, 2021 </div>
  </li>
    

    
  
    

    
    

    

    
      <li class="l0 storyItem">
    
      
      <a href="https://www.riverfronttimes.com/foodblog/2021/11/04/st-louis-bakery-will-help-local-girl-in-viral-video-receive-treatment-for-rare-disease?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RecentByTag">
        <img src="https://media2.fdncms.com/riverfronttimes/imager/u/bigsquare/36544348/lylapreview.jpg"
             alt="St. Louis Bakery Will Help Local Girl in Viral Video Receive Treatment for Rare Disease"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/foodblog/2021/11/04/st-louis-bakery-will-help-local-girl-in-viral-video-receive-treatment-for-rare-disease?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RecentByTag">St. Louis Bakery Will Help Local Girl in Viral Video Receive Treatment for Rare Disease</a>
    </h4>
    <div class="date"> Nov  4, 2021 </div>
  </li>
    

    
  
    

    
    

    

    
      <li class="l0 storyItem">
    
      
      <a href="https://www.riverfronttimes.com/artsblog/2021/11/04/missouri-history-museum-hosts-dia-de-los-muertos-festival-this-weekend?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RecentByTag">
        <img src="https://media2.fdncms.com/riverfronttimes/imager/u/bigsquare/36543860/diadepreview.jpg"
             alt="Missouri History Museum Hosts D&iacute;a de los Muertos Festival This Weekend"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/artsblog/2021/11/04/missouri-history-museum-hosts-dia-de-los-muertos-festival-this-weekend?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RecentByTag">Missouri History Museum Hosts Día de los Muertos Festival This Weekend</a>
    </h4>
    <div class="date"> Nov  4, 2021 </div>
  </li>
    

    
  
        

        

        
          <li class="l0 storyItem more">
            <a href="https://www.riverfronttimes.com/stlouis/ArticleArchives?tag=St.%20Louis%20news%7C%7CSt.%20Louis%7C%7CMissouri%7C%7Cpediatric%20covid%20vaccine%7C%7CCOVID-19%20vaccine%7C%7Cwhere%20to%20get%20kids%20covid%20vaccine%7C%7CSt.%20Louis%20Public%20Schools" class="more">More &raquo;</a>
          </li>
        
        </ul>
      </div>
    
  









  

  

  

  
    <div id="Disqus" class="SpanningFeature BlogPost ">
      <div id="disqus_thread"></div>
      <script type="text/javascript">
      <!--
        var disqus_shortname = "riverfronttimes2";
        var disqus_identifier = "riverfronttimes:36544591";
        var disqus_url = "https://www.riverfronttimes.com/newsblog/2021/11/04/st-louis-city-joins-forces-with-local-schools-to-vaccinate-kids-against-covid-19";
        var disqus_title = "St. Louis City Joins Forces With Local Schools to Vaccinate Kids Against COVID-19";
        (function() {
            var dsq = document.createElement("script"); dsq.type = "text/javascript"; dsq.async = true;
            dsq.src = "https://" + disqus_shortname + ".disqus.com/embed.js";
            (document.getElementsByTagName("head")[0] || document.getElementsByTagName("body")[0]).appendChild(dsq);
        })();
      // -->
      </script>
      <noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
    </div>
  






















  

  

  
    <div id="MorebyThisAuthorWrapper" class="SpanningFeature BlogPost Wrapper">

    
      
      
          <div id="MorebyThisAuthor" class="SpanningFeature BlogPost ">
            <h3><span class="headingText">More by Jenna Jones</span></h3>
            <ul class="moduleList">
        
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.riverfronttimes.com/foodblog/2021/11/04/st-louis-bakery-will-help-local-girl-in-viral-video-receive-treatment-for-rare-disease?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">
        <img src="https://media2.fdncms.com/riverfronttimes/imager/u/bigsquare/36544348/lylapreview.jpg"
             alt="St. Louis Bakery Will Help Local Girl in Viral Video Receive Treatment for Rare Disease"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/foodblog/2021/11/04/st-louis-bakery-will-help-local-girl-in-viral-video-receive-treatment-for-rare-disease?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">St. Louis Bakery Will Help Local Girl in Viral Video Receive Treatment for Rare Disease</a>
    </h4>
    <div class="date"> Nov  4, 2021 </div>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.riverfronttimes.com/artsblog/2021/11/04/missouri-history-museum-hosts-dia-de-los-muertos-festival-this-weekend?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">
        <img src="https://media2.fdncms.com/riverfronttimes/imager/u/bigsquare/36543860/diadepreview.jpg"
             alt="Missouri History Museum Hosts D&iacute;a de los Muertos Festival This Weekend"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/artsblog/2021/11/04/missouri-history-museum-hosts-dia-de-los-muertos-festival-this-weekend?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">Missouri History Museum Hosts Día de los Muertos Festival This Weekend</a>
    </h4>
    <div class="date"> Nov  4, 2021 </div>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.riverfronttimes.com/musicblog/2021/11/03/trans-siberian-orchestra-celebrating-album-anniversary-with-25-tickets?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">
        <img src="https://media1.fdncms.com/riverfronttimes/imager/u/bigsquare/36538562/transsiberianphoto.jpg"
             alt="Trans-Siberian Orchestra Celebrating Album Anniversary With $25 Tickets"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/musicblog/2021/11/03/trans-siberian-orchestra-celebrating-album-anniversary-with-25-tickets?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">Trans-Siberian Orchestra Celebrating Album Anniversary With $25 Tickets</a>
    </h4>
    <div class="date"> Nov  3, 2021 </div>
  </li>
        
        

      
             <li class="l0 storyItem more">
               <a href="https://www.riverfronttimes.com/stlouis/ArticleArchives?author=32960426" class="more">More &raquo;</a>
             </li>
             </ul>
          </div>
        
    
   </div>  
   
  










  

               



  
  

  

  

  <div id="BlogHeader" class="SpanningFeature BlogPost   newsblog">
    <a href="https://www.riverfronttimes.com/blogs/newsblog/">
    <div class="newsblog">
      
        News Blog
      
    </div>
    </a>

    

    <p>
      
        <a href="https://www.riverfronttimes.com/stlouis/newsblog/blogs/Archives">Archives</a> |
        <a href="/stlouis/Rss.xml?category=2512888">RSS</a>
      
      
    </p>
  </div>








      </div><!-- gridSpanningFeature -->
      
      <div id="gridSpanningFeature2">
        
      </div><!-- gridSpanningFeature2 -->

      <div id="gridColumnContainer" class="clearfix">

        <div id="gridMainColumn1">
          
        </div><!-- gridMainColumn1 -->
        
        <div id="gridMainColumn2">
          
        </div><!-- gridMainColumn2 -->

      </div><!-- end gridColumnContainer -->

    </div><!-- end gridFrame -->

    <div id="gridRightColumn">   
      <div id="gridSpanningIsland">
        









<div id="TabbedPopularity" class="SpanningIsland BlogPost ">
  <h2>Most Popular</h2>
  <div class="tabs">
    <div id="tabViewed" class="tabCurrent tab"><a href="#">Most Read</a></div>
    <div id="tabCommented" class="tabBack tab"><a href="#">Most Commented</a></div>
    <div id="tabLatest" class="tabBack tab tabLast"><a href="#">This Issue</a></div>
  </div>
  
  

  <div class="popularityBody">
    

    
      
          <ol class="moduleList">
        
        
        <li>
          <h4 class="headline"><a href="https://www.riverfronttimes.com/stlouis/coming-out-in-1994-nearly-cost-rodney-wilson-his-teaching-job-has-missouri-learned-anything/Content?oid=36536936&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Coming Out in 1994 Nearly Cost Rodney Wilson His Teaching Job. Has Missouri Learned Anything? <span class="more">Read More</span></a></h4>
        </li>
        
      
        
        <li>
          <h4 class="headline"><a href="https://www.riverfronttimes.com/stlouis/in-the-rush-to-build-the-next-napa-valley-what-happens-to-augusta/Content?oid=36495441&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">In the Rush to Build the Next Napa Valley, What Happens to Augusta? <span class="more">Read More</span></a></h4>
        </li>
        
      
        
        <li>
          <h4 class="headline"><a href="https://www.riverfronttimes.com/newsblog/2021/11/03/rev-darryl-gray-wins-right-to-jury-trial-in-4-year-old-police-abuse-case?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Rev. Darryl Gray Wins Right to Jury Trial in 4-Year-Old Police Abuse Case <span class="more">Read More</span></a></h4>
        </li>
        
      
        
        <li>
          <h4 class="headline"><a href="https://www.riverfronttimes.com/newsblog/2021/11/04/from-ferguson-to-st-louis-twelve-miles-and-seven-years?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">From Ferguson to St. Louis: Twelve Miles and Seven Years <span class="more">Read More</span></a></h4>
        </li>
        
      
        
        <li>
          <h4 class="headline"><a href="https://www.riverfronttimes.com/newsblog/2021/11/03/children-can-get-their-covid-19-vaccine-at-walgreens-beginning-saturday?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Children Can Get Their COVID-19 Vaccine at Walgreens Beginning Saturday <span class="more">Read More</span></a></h4>
        </li>
        
      
          </ol>
        
    
  </div>  

  

  <div class="popularityBody" style="display:none">
    

    
    <div id="recentcomments" class="dsq-widget"><script type="text/javascript" src="https://disqus.com/forums/riverfronttimes2/popular_threads_widget.js?num_items=5&hide_avatars=1&avatar_size=32&excerpt_length=200"></script></div>
  </div>
  
  

  <div class="popularityBody" style="display:none">
    
    
      <div class="currentIssue">
        <a href="https://www.riverfronttimes.com/stlouis/IssueArchives?issue=36533098&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity" class="no-foundation-imgeditor">
          
            <img src="/imager/b/cover/36533098/4786/RFT_11.03.21_Cover.jpg" alt="Issue Cover" />
          
        </a>
        <p>November  3- 9, 2021</p>
      </div>
    
    
        <ol class="moduleList">
      
        
      <li>
        <h4 class="headline"><a href="https://www.riverfronttimes.com/stlouis/heres-what-to-see-at-the-st-louis-international-film-festival/Content?oid=36540434&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Here's What to See at the St. Louis International Film Festival <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.riverfronttimes.com/stlouis/coming-out-in-1994-nearly-cost-rodney-wilson-his-teaching-job-has-missouri-learned-anything/Content?oid=36536936&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Coming Out in 1994 Nearly Cost Rodney Wilson His Teaching Job. Has Missouri Learned Anything? <span class="more">Read More</span></a></h4>
      </li>
      
    
        </ol>
      
  </div>
</div>



<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function () {
    dnSetupTabGroup(
        $$("#TabbedPopularity div.tabs>div"),
        $$("#TabbedPopularity div.popularityBody"),
        "tabCurrent", "tabBack"
    );
    
    // Deactivate links.
    $$("#TabbedPopularity div.tabs>div a").each(function (a) {
        a.onclick = function () { 
          setTimeout(function(){ jQuery('#TabbedPopularity li').css('counter-reset','item'); },10);
          return false; 
        };
    });
});
//-->
</script>
<!-- End #TabbedPopularity -->












<div id="SearchRightCol" class="SpanningIsland BlogPost  search-wrap">
    
    <form class="prepTextForm" id="searchbox_007740603287178168358:htmjd4xll5w" action="https://posting.riverfronttimes.com/stlouis/Search">
      <input type="hidden" name="cx" value="007740603287178168358:htmjd4xll5w" />
      <input type="hidden" name="cof" value="FORID:9" />
      <input id="search-submit" type="submit" name="sa" value="Search" />    
      <input id="search-input" autocomplete="off" type="text"  name="q" size="25" placeholder="Search" />
    </form>
    <ul id="search-dropdown"  class="search-dropdown" style="display:none;">
      <li class="search-option"><a class="search-all" href="https://posting.riverfronttimes.com/stlouis/Search?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SearchRightCol"><span class="dark-search-icon"></span>&nbsp;All</a></li>
      <li class="search-option"><a href="https://www.riverfronttimes.com/stlouis/ArticleArchives?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SearchRightCol"><span class="dark-search-icon"></span>&nbsp;in Articles &amp; Posts</a></li>
      <li class="search-option"><a href="https://www.riverfronttimes.com/stlouis/EventSearch?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SearchRightCol"><span class="dark-search-icon"></span>&nbsp;in Events</a></li>
      <li class="search-option"><a href="https://www.riverfronttimes.com/stlouis/LocationSearch?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SearchRightCol"><span class="dark-search-icon"></span>&nbsp;in Locations</a></li>
    </ul>
  
</div>

<script type="text/javascript">
/* SEARCH WIDGET */

var searchInputSelector = '#search-input';
var searchFormSelector = 'form.prepTextForm';

dropDownLinksEmptyKeywordAlert = function (){
  jQuery(searchInputSelector).attr('placeholder','Please enter a keyword.');
  setTimeout(function(){jQuery(searchInputSelector).attr('placeholder','Search');},3000);
}

// 
jQuery(searchFormSelector+' input[type="submit"]').click(function(e){
  jQuery(searchInputSelector).click();
  if(jQuery(searchInputSelector).val() == ""){
    e.preventDefault();
    dropDownLinksEmptyKeywordAlert();
  }
});

dropDownLinks = new FloatingPanel(
  'search-input', // 
  'search-dropdown', // 
  {
    effects: 'off',
    closeDelay: 1,
    triggerEvent: 'click',
    allowDefault: true,
    beforeOpen: function() {
      var searchInput = jQuery(searchInputSelector);
      jQuery('.search-option a').click(function(e){
        e.preventDefault(); // 
        // 
        if(jQuery(searchInputSelector).val() != ""){
          if(jQuery(e.target).hasClass('search-all')){
            jQuery(searchFormSelector).submit();
          } else {
            var newLocation = jQuery(e.target).attr('href') || "";
            if( newLocation.match(/\?/)){
              newLocation = newLocation+'&';
            }else{
              newLocation = newLocation+'?';
            }
            window.location = newLocation + "keywords=" + jQuery(searchInputSelector).val() +  "&submit=Search";
          }
        }else{
          dropDownLinksEmptyKeywordAlert();
        }
      });

      //
      SearchRightColCloseSearchPanel = function(event){
        if(jQuery(event.target).parents('#SearchRightCol').length == 0){
          dropDownLinks.closePanel();
        }
      }
      jQuery(document).click(function(e){SearchRightColCloseSearchPanel(e);});
    },
    beforeClose: function() {
      //
      jQuery(document).off('click', '*', SearchRightColCloseSearchPanel);
    },
    togglePanel: function(){
      //
    }
  }
);
</script>
<!-- End #SearchRightCol -->
<div id="AdMediumRectangle1300x250" class="SpanningIsland BlogPost ">
  <!-- /43707298/STL_300x250 -->
          <div id="div-gpt-ad-stl_300x250-1" style="" data-content-type="ad" data-slot="/43707298/STL_300x250" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-stl_300x250-1');
                });
              </script>
          </div>
</div>


  <div id="CurrentIssuu" class="SpanningIsland BlogPost ">
    <h2>Read the Digital Print Issue</h2>
    <div class="wrap">
      
        <h3>November  3, 2021</h3>

        <iframe src="https://e.issuu.com/embed.html?d=rft_110321&hideIssuuLogo=true&pageLayout=singlePage&u=euclidmediagroup" allowfullscreen allow="fullscreen" style="border:none;width:100%;height:300px;"></iframe>

        <p style="margin:10px 0;">
          <a class="more" href="https://www.riverfronttimes.com/stlouis/IssueArchives">View more issues</a>
        </p>
      
    </div>
  </div>
  
<div id="AdMediumRectangle2300x250" class="SpanningIsland BlogPost ">
  <!-- /43707298/STL_300x250 -->
          <div id="div-gpt-ad-stl_300x250-2" style="" data-content-type="ad" data-slot="/43707298/STL_300x250" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-stl_300x250-2');
                });
              </script>
          </div>
</div>


  <div id="PhotoSlideshows" class="SpanningIsland BlogPost ">
    <h2><a href="http://photos.riverfronttimes.com" target="_blank">Newest Slideshows</a></h2>
    <iframe src="https://www.riverfronttimes.com/gyrobase/blogs/Post?ajaxComponent=PhotoSlideshows&iframeRendered=yes" 
            height="419" 
            width="364"
            scrolling="no" 
            frameborder="0"></iframe>
  </div>
  <!-- End #PhotoSlideshows -->



  <div id="NewsletterSignup" class="SpanningIsland BlogPost ">
  <h2>Newsletters</h2>
    <div class="wrap">
    <!-- BEGIN: Constant Contact Email List Form Button -->
<h3>Never miss a beat</h3>
<a href="/stlouis/Newsletters/Page" style="float:right;border: 0; color: rgb(255, 255, 255); display: inline-block; padding: 8px 15px; text-shadow: none; border-top-left-radius: 8px; border-top-right-radius: 8px; border-bottom-right-radius: 8px; border-bottom-left-radius: 8px; background-color: rgb(217, 31, 52);font-family:'Montserrat',sans-serif;text-transform: uppercase;text-decoration:none;">Sign Up Now</a>
<p>Subscribe now to get the latest news delivered right to your inbox.</p>
<!-- END: Constant Contact Email List Form Button -->
    </div>
  </div>
  
















    <div id="SpecialIssues" class="SpanningIsland BlogPost ">
      <h2><a href="https://www.riverfronttimes.com/stlouis/special-issues/Section?oid=2348807&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues">Special Issues</a></h2>
  
  
  <div class="reportBox">
    <a href="/stlouis/summer-guide/Category?oid=2349249&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media2.fdncms.com/riverfronttimes/imager/u/original/2773484/summerguide.jpg);">
      <span class="grayRedBox">Summer Guide</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/musicblog/archives/music-issue/?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media2.fdncms.com/riverfronttimes/imager/u/original/2773487/musicissue.jpg);">
      <span class="grayRedBox">Music Issue</span>
    </a>
  </div>
  

      <a href="https://www.riverfronttimes.com/stlouis/special-issues/Section?oid=2348807&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues">More...</a>
    </div>
  
<div id="AdMediumRectangle3300x250" class="SpanningIsland BlogPost ">
  <!-- /43707298/STL_300x250 -->
          <div id="div-gpt-ad-stl_300x250-3" style="" data-content-type="ad" data-slot="/43707298/STL_300x250" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-stl_300x250-3');
                });
              </script>
          </div>
</div>









































<div id="TabbedCalendar" class="SpanningIsland BlogPost ">
  <h2>Best Things to Do In St. Louis</h2>

  <div class="tabs">
    <div id="tabEvents" class="tab"><a href="#">Events</a></div>
    <div id="tabMusic"  class="tab"><a href="#">Music</a></div>
    <div id="tabMovies" class="tab"><a href="#">Movies</a></div>
    <div id="tabArts"   class="tab"><a href="#">Arts</a></div>
    <div id="tabDining" class="tab tabLast"><a href="#">Dining</a></div>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
    <a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?narrowByDate=Today&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
    <a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?narrowByDate=Tomorrow&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
    <a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?narrowByDate=This%20Weekend&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
  </div>
    <ol class="moduleList">
    
      <li>
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/stlouis/easterseals-midwest-virtual-autism-conference/Event?oid=36499935&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Easterseals Midwest Virtual Autism Conference <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/stlouis/anti-poverty-advocates-summit/Event?oid=36419202&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Anti-Poverty Advocates Summit <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/stlouis/dj-g-wiz-live-at-the-turntables/Event?oid=36418958&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        DJ G. Wiz, Live at the Turntables <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/stlouis/ncjwstls-writing-your-story-with-ellen-futterman/Event?oid=36446847&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        NCJWSTL's Writing Your Story with Ellen Futterman <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/stlouis/jon-bunge-presence/Event?oid=36429757&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Jon Bunge: Presence <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
  </ol>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
    <a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?eventSection=2759668&amp;narrowByDate=Today&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
    <a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?eventSection=2759668&amp;narrowByDate=Tomorrow&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
    <a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?eventSection=2759668&amp;narrowByDate=This%20Weekend&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
  </div>
    <ol class="moduleList">
    
      <li>
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/stlouis/sittin-on-the-porch/Event?oid=36214485&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Sittin’ On the Porch <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/stlouis/boogie-chyld-live-at-the-attic/Event?oid=36451476&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Boogie Chyld live at The Attic! <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/stlouis/cheri-evans/Event?oid=36214470&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Cheri Evans <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/stlouis/rickey-smiley/Event?oid=35959432&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Rickey Smiley <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/stlouis/joe-park-and-the-hot-club-of-st-louis/Event?oid=36429758&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Joe Park & The Hot Club of St. Louis <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
  </ol>
  </div>  

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
    <a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?eventSection=2762983&amp;narrowByDate=Today&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
    <a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?eventSection=2762983&amp;narrowByDate=Tomorrow&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
    <a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?eventSection=2762983&amp;narrowByDate=This%20Weekend&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
  </div>
    <ol class="moduleList">
      
        <li>
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/stlouis/papaw-land-film-screening-st-louis-international-film-festival/Event?oid=36509657&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        "Papaw Land" Film Screening (St. Louis International Film Festival) <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/stlouis/thursday-nights-at-the-museum-hollywood-vs-history-band-of-brothers/Event?oid=36425325&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Thursday Nights at the Museum: Hollywood vs. History: “Band of Brothers” <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/stlouis/thursday-nights-at-the-museum-band-of-brothers/Event?oid=36429989&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Thursday Nights at the Museum: Band of Brothers <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
    </ol>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
    <a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?eventSection=2762986&amp;narrowByDate=Today&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
    <a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?eventSection=2762986&amp;narrowByDate=Tomorrow&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
    <a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?eventSection=2762986&amp;narrowByDate=This%20Weekend&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
  </div>
    <ol class="moduleList">
    
      <li>
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/stlouis/jon-bunge-presence/Event?oid=36429757&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Jon Bunge: Presence <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/stlouis/mary-engelbreit-then-and-now-art-exhibit/Event?oid=36311202&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Mary Engelbreit: Then and Now Art Exhibit <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/stlouis/jakes-women/Event?oid=36385730&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Jake's Women <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/stlouis/currents-120-jess-t-dugan/Event?oid=36110421&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Currents 120: Jess T. Dugan <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/stlouis/art-of-darkness-a-juried-art-exhibit/Event?oid=36316355&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Art of Darkness - a juried art exhibit <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
  </ol>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <ol class="moduleList">
      
        <li>
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/stlouis/jf-sanfilippos/Location?oid=2687974&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        J.F. Sanfilippo's <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/stlouis/mcmurphys-grill/Location?oid=2683948&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        McMurphy's Grill <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="https://www.riverfronttimes.com/stlouis/river-city-roasters/Location?oid=2687787&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        River City Roasters <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
    </ol>
    <form name="diningSearchForm" method="get" action="https://www.riverfronttimes.com/stlouis/LocationSearch">
      <input type="hidden" name="locationSection" value="2683245" />
      <input type="hidden" name="guide" value="2124367" />
      <select name="locationCategory">
        <option value="">-All Categories-</option>
        
          <option value="2683451">Afghan</option>
        
          <option value="2683449">African</option>
        
          <option value="2683395">American</option>
        
          <option value="2683320">Appetizers</option>
        
          <option value="2683393">Armenian</option>
        
          <option value="2683466">Asian</option>
        
          <option value="2683480">Asian Fusion</option>
        
          <option value="2683434">Austrian</option>
        
          <option value="2683468">Bakery</option>
        
          <option value="2683360">Bar Food</option>
        
          <option value="2683465">Barbecue</option>
        
          <option value="2683505">Beignet</option>
        
          <option value="2683431">Belgian</option>
        
          <option value="2683404">Bistro</option>
        
          <option value="2683313">Bosnian</option>
        
          <option value="2683378">Brazilian</option>
        
          <option value="2683334">Breakfast</option>
        
          <option value="2683366">Brewery</option>
        
          <option value="2683495">British</option>
        
          <option value="2683368">Brunch</option>
        
          <option value="2683460">Buffet</option>
        
          <option value="2683351">Burgers</option>
        
          <option value="2683371">Butcher Shop</option>
        
          <option value="2683379">Cafe</option>
        
          <option value="2683407">Cajun</option>
        
          <option value="2683286">California</option>
        
          <option value="2683467">Caribbean</option>
        
          <option value="2683391">Central American</option>
        
          <option value="2683447">Chinese</option>
        
          <option value="2683314">Coffeehouse</option>
        
          <option value="2683398">Comfort Foods</option>
        
          <option value="2683408">Contemporary</option>
        
          <option value="2683444">Continental</option>
        
          <option value="2683484">Creole</option>
        
          <option value="2683430">Crepes</option>
        
          <option value="2683285">Cuban</option>
        
          <option value="2683325">Deli</option>
        
          <option value="2683390">Dessert</option>
        
          <option value="2683332">Diner</option>
        
          <option value="2683383">Eclectic</option>
        
          <option value="2683311">English</option>
        
          <option value="2683301">Eritrean</option>
        
          <option value="2683481">Ethiopian</option>
        
          <option value="2683341">European</option>
        
          <option value="2683475">Fast Casual</option>
        
          <option value="2683433">Fast Food</option>
        
          <option value="2683300">Filipino</option>
        
          <option value="2683485">Fine Dining</option>
        
          <option value="2683411">Fondue</option>
        
          <option value="2683270">Food Trucks</option>
        
          <option value="2683376">French</option>
        
          <option value="2683482">Fried Chicken</option>
        
          <option value="2683338">Frozen Yogurt</option>
        
          <option value="2683420">Fusion</option>
        
          <option value="2683339">Gastro Pub</option>
        
          <option value="2683388">Gelato</option>
        
          <option value="2683424">German</option>
        
          <option value="2683331">Gluten-Free</option>
        
          <option value="2683349">Gourmet</option>
        
          <option value="2683348">Greek</option>
        
          <option value="2683330">Grill</option>
        
          <option value="2683370">Grocery</option>
        
          <option value="2683471">Gyros</option>
        
          <option value="2683497">Halal</option>
        
          <option value="2683477">Health</option>
        
          <option value="2683342">Hot Dogs</option>
        
          <option value="2683377">Ice Cream</option>
        
          <option value="2683305">Indian</option>
        
          <option value="2683381">Indonesian</option>
        
          <option value="2683309">International</option>
        
          <option value="2683427">Irish</option>
        
          <option value="2683374">Italian</option>
        
          <option value="2683296">Jamaican</option>
        
          <option value="2683323">Japanese</option>
        
          <option value="2683345">Jewish</option>
        
          <option value="2683372">Korean</option>
        
          <option value="2683413">Kosher</option>
        
          <option value="2683316">Latin</option>
        
          <option value="2683401">Latin American</option>
        
          <option value="2683299">Lebanese</option>
        
          <option value="2683501">Market</option>
        
          <option value="2683284">Mediterranean</option>
        
          <option value="2683500">Mexican</option>
        
          <option value="2683450">Middle Eastern</option>
        
          <option value="2683428">Modern American</option>
        
          <option value="2683396">Modern European</option>
        
          <option value="2683367">Mongolian</option>
        
          <option value="2683498">Moroccan</option>
        
          <option value="2683426">Nepalese</option>
        
          <option value="2683290">New American</option>
        
          <option value="2683362">Organic</option>
        
          <option value="2683298">Pakistani</option>
        
          <option value="2683442">Paleo</option>
        
          <option value="2683355">Pan-Asian</option>
        
          <option value="2683483">Paninis</option>
        
          <option value="2683397">Pasta</option>
        
          <option value="2683302">Pastries</option>
        
          <option value="2683382">Persian</option>
        
          <option value="2683402">Peruvian</option>
        
          <option value="2683502">Pizza</option>
        
          <option value="2683496">Polynesian</option>
        
          <option value="2683329">Raw Food</option>
        
          <option value="2683414">Recommended</option>
        
          <option value="2683249">Restaurants</option>
        
          <option value="2683303">Russian</option>
        
          <option value="2683438">Salads</option>
        
          <option value="2683356">Sandwiches</option>
        
          <option value="2683479">Scottish</option>
        
          <option value="2683308">Seafood</option>
        
          <option value="2683489">Sicilian</option>
        
          <option value="2683389">Small Plates</option>
        
          <option value="2683476">Smoothies</option>
        
          <option value="2683343">Soul Food</option>
        
          <option value="2683440">Soups</option>
        
          <option value="2683416">South American</option>
        
          <option value="2683457">Southern</option>
        
          <option value="2683493">Southwestern</option>
        
          <option value="2683456">Spanish</option>
        
          <option value="2683478">Specialties</option>
        
          <option value="2683490">Steakhouse</option>
        
          <option value="2683453">Street Food</option>
        
          <option value="2683459">Sushi</option>
        
          <option value="2683363">Syrian</option>
        
          <option value="2683488">Tapas</option>
        
          <option value="2683353">Tea</option>
        
          <option value="2683446">Tex-Mex</option>
        
          <option value="2683310">Thai</option>
        
          <option value="2683437">Traditional</option>
        
          <option value="2683295">Turkish</option>
        
          <option value="2683292">Tuscan</option>
        
          <option value="2683335">Vegan</option>
        
          <option value="2683297">Vegetarian</option>
        
          <option value="2683354">Vietnamese</option>
        
          <option value="2683470">Welsh</option>
        
          <option value="2683328">Wine Bar</option>
        
          <option value="2683318">Wings</option>
        
          <option value="2683369">Wraps</option>
        
      </select>
      <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        
          <option value="2682456" >ST. LOUIS - DOWNTOWN/ MIDTOWN</option>
        
        <option value="2682516" >&nbsp;&nbsp;St. Louis - Central West End</option>
      
        
        <option value="2682518" >&nbsp;&nbsp;St. Louis - Downtown</option>
      
        
        <option value="2682519" >&nbsp;&nbsp;St. Louis - Forest Park</option>
      
        
        <option value="2682521" >&nbsp;&nbsp;St. Louis - Grand Center</option>
      
        
        <option value="2682522" >&nbsp;&nbsp;St. Louis - Lafayette Square</option>
      
        
        <option value="2682523" >&nbsp;&nbsp;St. Louis - Midtown</option>
      
        
        <option value="2682502" >&nbsp;&nbsp;St. Louis - North Downtown</option>
      
        
        <option value="2682524" >&nbsp;&nbsp;St. Louis - Riverfront</option>
      
        
        <option value="2682525" >&nbsp;&nbsp;St. Louis - Skinker/DeBaliviere</option>
      
        
        <option value="2682530" >&nbsp;&nbsp;St. Louis - Washington Avenue</option>
      
        
          <option value="2682457" >ST. LOUIS - NORTH CITY</option>
        
        <option value="2682499" >&nbsp;&nbsp;St. Louis - Bellefontaine</option>
      
        
        <option value="2682500" >&nbsp;&nbsp;St. Louis - Fairground Park</option>
      
        
        <option value="2682501" >&nbsp;&nbsp;St. Louis - North City</option>
      
        
          <option value="2682458" >ST. LOUIS - SOUTH CITY</option>
        
        <option value="2682517" >&nbsp;&nbsp;St. Louis - Dogtown</option>
      
        
        <option value="2682520" >&nbsp;&nbsp;St. Louis - Forest Park Southeast</option>
      
        
        <option value="2682538" >&nbsp;&nbsp;St. Louis - Soulard</option>
      
        
        <option value="2682503" >&nbsp;&nbsp;St. Louis - South City</option>
      
        
        <option value="2682527" >&nbsp;&nbsp;St. Louis - South Grand</option>
      
        
        <option value="2682504" >&nbsp;&nbsp;St. Louis - St. Louis Hills</option>
      
        
        <option value="2682535" >&nbsp;&nbsp;St. Louis - The Grove</option>
      
        
        <option value="2682528" >&nbsp;&nbsp;St. Louis - The Hill</option>
      
        
        <option value="2682529" >&nbsp;&nbsp;St. Louis - Tower Grove</option>
      
        
          <option value="2682450" >METRO EAST</option>
        
        <option value="2682464" >&nbsp;&nbsp;Belleville/ Fairview Heights</option>
      
        
        <option value="2682468" >&nbsp;&nbsp;Collinsville/ Edwardsville</option>
      
        
        <option value="2682472" >&nbsp;&nbsp;Dupo/ Columbia</option>
      
        
        <option value="2682473" >&nbsp;&nbsp;East St. Louis/ Cahokia</option>
      
        
        <option value="2682478" >&nbsp;&nbsp;Grafton/ Godfrey/ Alton</option>
      
        
        <option value="2682479" >&nbsp;&nbsp;Granite City</option>
      
        
        <option value="2682507" >&nbsp;&nbsp;Venice/ Madison/ Brooklyn</option>
      
        
          <option value="2682451" >NORTH ST. LOUIS COUNTY</option>
        
        <option value="2682463" >&nbsp;&nbsp;Airport</option>
      
        
        <option value="2682475" >&nbsp;&nbsp;Ferguson</option>
      
        
        <option value="2682476" >&nbsp;&nbsp;Florissant</option>
      
        
        <option value="2682483" >&nbsp;&nbsp;Jennings</option>
      
        
        <option value="2682490" >&nbsp;&nbsp;North St. Louis County</option>
      
        
        <option value="2682496" >&nbsp;&nbsp;St. Ann</option>
      
        
          <option value="2682454" >SOUTH ST. LOUIS COUNTY</option>
        
        <option value="2682462" >&nbsp;&nbsp;Affton/ Concord</option>
      
        
        <option value="2682470" >&nbsp;&nbsp;Crestwood/ Sunset Hills/ Sappington/ South Lindbergh</option>
      
        
        <option value="2682474" >&nbsp;&nbsp;Fenton</option>
      
        
        <option value="2682489" >&nbsp;&nbsp;Mehlville/ Oakville/ Lemay</option>
      
        
          <option value="2682445" >CENTRAL ST. LOUIS COUNTY</option>
        
        <option value="2682465" >&nbsp;&nbsp;Brentwood</option>
      
        
        <option value="2682487" >&nbsp;&nbsp;Maplewood</option>
      
        
        <option value="2682495" >&nbsp;&nbsp;Richmond Heights</option>
      
        
          <option value="2682459" >WEST ST. LOUIS COUNTY</option>
        
        <option value="2682466" >&nbsp;&nbsp;Chesterfield</option>
      
        
        <option value="2682471" >&nbsp;&nbsp;Creve Coeur</option>
      
        
        <option value="2682512" >&nbsp;&nbsp;Des Peres</option>
      
        
        <option value="2682513" >&nbsp;&nbsp;Eureka</option>
      
        
        <option value="2682514" >&nbsp;&nbsp;Frontenac</option>
      
        
        <option value="2682480" >&nbsp;&nbsp;Hazelwood/ Bridgeton/ Earth City</option>
      
        
        <option value="2682486" >&nbsp;&nbsp;Manchester/ Ballwin</option>
      
        
        <option value="2682488" >&nbsp;&nbsp;Maryland Heights</option>
      
        
        <option value="2682531" >&nbsp;&nbsp;Town & Country</option>
      
        
        <option value="2682506" >&nbsp;&nbsp;Valley Park</option>
      
        
        <option value="2682510" >&nbsp;&nbsp;Wildwood</option>
      
        
          <option value="2682446" >CLAYTON/ U. CITY/ LADUE</option>
        
        <option value="2682467" >&nbsp;&nbsp;Clayton</option>
      
        
        <option value="2682511" >&nbsp;&nbsp;Delmar/ The Loop</option>
      
        
        <option value="2682485" >&nbsp;&nbsp;Ladue</option>
      
        
        <option value="2682515" >&nbsp;&nbsp;Olive Boulevard</option>
      
        
        <option value="2682494" >&nbsp;&nbsp;Olivette/ Overland</option>
      
        
        <option value="2682532" >&nbsp;&nbsp;University City</option>
      
        
          <option value="2682449" >KIRKWOOD/ WEBSTER GROVES</option>
        
        <option value="2682484" >&nbsp;&nbsp;Kirkwood</option>
      
        
        <option value="2682508" >&nbsp;&nbsp;Webster Groves</option>
      
        
          <option value="2682455" >ST. CHARLES COUNTY</option>
        
        <option value="2682491" >&nbsp;&nbsp;O'Fallon, MO</option>
      
        
        <option value="2682497" >&nbsp;&nbsp;St. Charles</option>
      
        
        <option value="2682498" >&nbsp;&nbsp;St. Charles County</option>
      
        
        <option value="2682505" >&nbsp;&nbsp;St. Peters</option>
      
        
        <option value="2682509" >&nbsp;&nbsp;Wentzville</option>
      
        
          <option value="3081641" >HERMANN</option>
        
        <option value="3081642" >&nbsp;&nbsp;Hermann</option>
      
        
          <option value="2682448" >JEFFERSON COUNTY</option>
        
        <option value="2682482" >&nbsp;&nbsp;Jefferson County</option>
      
        
          <option value="2682453" >OUTSTATE MO</option>
        
        <option value="2682469" >&nbsp;&nbsp;Columbia</option>
      
        
        <option value="2682481" >&nbsp;&nbsp;Jefferson City</option>
      
        
        <option value="2682533" >&nbsp;&nbsp;Lexington</option>
      
        
        <option value="2682493" >&nbsp;&nbsp;Outstate MO</option>
      
        
          <option value="2682447" >FRANKLIN COUNTY</option>
        
        <option value="2682477" >&nbsp;&nbsp;Franklin County</option>
      
        
          <option value="2682452" >OUTSTATE IL</option>
        
        <option value="2682534" >&nbsp;&nbsp;Murphysboro</option>
      
        
        <option value="2682492" >&nbsp;&nbsp;Outstate IL</option>
      
        
        <option value="2682537" >&nbsp;&nbsp;St. Libory</option>
      
        
          <option value="33361219" >ONLINE</option>
        
        <option value="33361220" >&nbsp;&nbsp;Online Only</option>
      
        
          <option value="2682460" >OUT OF TOWN</option>
        
        <option value="2682536" >&nbsp;&nbsp;Out of Town</option>
      
        
          <option value="2682461" >BEYOND</option>
        
        <option value="2682539" >&nbsp;&nbsp;Unknown</option>
      
    
  </select>
      <div class="searchBox">
        <input type="text" name="keywords" title="Enter keyword" placeholder="Search" autocomplete="off" class="text" value="" />
        <input type="submit" value="go" />
      </div>
    </form>
  </div>
</div>



<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function () {
    dnSetupTabGroup(
        $$("#TabbedCalendar div.tabs>div"),
        $$("#TabbedCalendar div.eventTabGuts"),
        "tabCurrent", "tabBack", 0
    );

    // Deactivate links.
    $$("#TabbedCalendar div.tabs>div a").each(function (a) {
        a.onclick = function () { 
          setTimeout(function(){ jQuery('#TabbedCalendar li').css('counter-reset','item'); },10);
          return false; 
        };
    });
});
//-->
</script>

      </div><!-- end gridSpanningIsland -->  
     
      <div id="gridMainSidebar">
        
      </div><!-- end gridMainSidebar -->

      <div id="gridAdSidebar">
        
      </div><!-- end gridAdSidebar -->
      
      <div id="gridBottomSidebar">
        
      </div>
    </div><!-- end gridRightColumn -->
    
    <!-- Footer -->
    <div id="gridFooter">
      

<div id="FooterInfo" class="GlobalFooter BlogPost ">
  <div class="footerCustomInfo">




    <h2>Riverfront Times</h2>
			<p>PO Box 179456</p>
			<p>St. Louis, MO 63117</p>
    <p>Main: (314) 754-5966</p>
    <p>Advertising: (314) 754-5914</p>
    <p>Classified: (314) 754-5925</p>
  </div>
  <div class="footerCustomWrap">
    <div class="footerCustomNav">
      <ul>
        <li><a target="_top" href="/stlouis/ContactUs/Page">Contact RFT</a></li>
        <li><a target="_top" href="https://www.riverfronttimes.com/stlouis/AdvertiseWithRiverfrontTimes/Page">Advertise</a></li>
        <li><a target="_blank" href="http://www.vmgadvertising.com/">National Advertising</a></li>
        <li><a target="_top" href="/stlouis/Jobs/Page">Work Here</a></li>
      </ul>
      <p>All parts of this site Copyright &copy; 2021 Riverfront Times.</p>
    </div>

    

    
    
      <div class="footerCustomLogin">
        

        
        <ul data-view="loggedin" style="display:none">
          <li><strong data-label="username">Username</strong> / </li>
          <li><a href="https://posting.riverfronttimes.com/stlouis/MyProfile">View Profile</a> / </li>
          <li><a href="https://posting.riverfronttimes.com/stlouis/Profile/MySettings">Edit Profile</a> / </li>
          <li><a href="https://www.riverfronttimes.com/stlouis/Logout">Log Out</a></li>
        </ul>

        <ul data-view="loggedout" style="display:none">
          <li><a href="#LogIn">Log in</a> / </li>
          <li><a href="#CreateAccount">Create Account</a></li>
        </ul>
      </div><!-- #FooterInfo -->

      <script>
        new Foundation.LoginRequiredComponent("FooterInfo");
      </script>
    
  </div>
  <div class="clear"></div>
</div>
<!-- End #FooterInfo -->
<div id="AdFooter728x90" class="GlobalFooter BlogPost ">
  <!-- /43707298/STL_728x90 -->
          <div id="div-gpt-ad-stl_728x90-2" style="" data-content-type="ad" data-slot="/43707298/STL_728x90" data-output="asynchronous" data-width="728" data-height="90">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-stl_728x90-2');
                });
              </script>
          </div>
</div>


















<div id="FooterNavigation" class="GlobalFooter BlogPost ">
  <div class="linkGroupColumn">

    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="###" 
               target="_">
              News
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/stlouis/news/Section?oid=2348800" target="_self">News Home</a></li>
          
            <li><a href="/stlouis/ArticleArchives?tag=coronavirus" target="_self">Coronavirus Updates</a></li>
          
            <li><a href="/stlouis/feature/Content?category=2349239" target="_self">News Features</a></li>
          
            <li><a href="/blogs/newsblog/" target="_self">News Blog</a></li>
          
            <li><a href="/stlouis/joblistings/Page" target="_self">Job Listings</a></li>
          
            <li><a href="/stlouis/IssueArchives?issue=thisweek" target="_blank">Digital Issue</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="###" 
               target="_">
              Music
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/stlouis/music/Section?oid=2348804" target="_self">Music Home</a></li>
          
            <li><a href="/stlouis/music-stories/Category?oid=2349233" target="_self">Music Features</a></li>
          
            <li><a href="/blogs/musicblog/" target="_self">Music Blog</a></li>
          
            <li><a href="/stlouis/EventSearch?feature=Concert" target="_self">Concert Listings</a></li>
          
            <li><a href="/stlouis/EventSearch?feature=Club" target="_self">Club Listings</a></li>
          
            <li><a href="/stlouis/bars-and-clubs/Category?oid=2349248" target="_self">Bars and Clubs Guide</a></li>
          
            <li><a href="/stlouis/Events/AddEvent" target="_self">Submit a Concert Listing</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/stlouis/GoodTo-GoStLouisADirectoryofLocalBusinessesYouCanSupportDuringtheCoronavirusEra/Page" 
               target="_">
              Eat
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/stlouis/GoodTo-GoStLouisADirectoryofLocalBusinessesYouCanSupportDuringtheCoronavirusEra/Page" target="_self">Good To-Go St. Louis</a></li>
          
            <li><a href="/stlouis/restaurants/Category?oid=2349238" target="_self">Restaurant Reviews</a></li>
          
            <li><a href="/stlouis/food-and-drink/Category?oid=2349246" target="_self">Food Features</a></li>
          
            <li><a href="/blogs/foodblog/" target="_self">Food Blog</a></li>
          
            <li><a href="/stlouis/LocationSearch?locationSection=2683245/stlouis/LocationSearch?locationSection=2683245&guide=2124367" target="_self">Dining Guide</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/stlouis/EventSearch" 
               target="_">
              Calendar
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/stlouis/EventSearch" target="_self">Events in St. Louis</a></li>
          
            <li><a href="/stlouis/EventSearch?feature=Concert" target="_self">Concert Listings</a></li>
          
            <li><a href="/stlouis/EventSearch?feature=Club" target="_self">Club Listings</a></li>
          
            <li><a href="/stlouis/Events/AddEvent" target="_self">Submit an Event</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/stlouis/arts-and-culture/Section?oid=2348805" 
               target="_">
              Arts
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/stlouis/arts-and-culture/Section?oid=2348805" target="_self">Arts Home</a></li>
          
            <li><a href="/stlouis/theater/Category?oid=2349241" target="_self">Theater Reviews</a></li>
          
            <li><a href="/stlouis/arts/Category?oid=2349234" target="_self">Arts Features</a></li>
          
            <li><a href="/blogs/artsblog/" target="_self">Arts Blog</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/stlouis/movies/Section?oid=2348802" 
               target="_">
              Movies
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/stlouis/movies/Section?oid=2348802" target="_self">Movie Reviews and News</a></li>
          
            <li><a href="/stlouis/LocationSearch?locationCategory=2683256&sortType=name" target="_self">Find a Theater</a></li>
          
            <li><a href="/stlouis/MovieTimes?show=theater" target="_self">Movie Times by Theater</a></li>
          
            <li><a href="/stlouis/MovieTimes" target="_self">Movie Times by Title</a></li>
          
            <li><a href="/stlouis/MovieTimes?show=times" target="_self">Movie Times by Time of Day</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>Special Sections</h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/stlouis/summer-guide/Category?oid=2349249" target="_self">Summer Guide</a></li>
          
            <li><a href="/stlouis/city-guide/Category?oid=3138571" target="_self">City Guide</a></li>
          
            <li><a href="/musicblog/archives/music-issue/" target="_self">Music Issue</a></li>
          
            <li><a href="/stlouis/BestOf" target="_self">Best of St. Louis</a></li>
          
            <li><a href="/stlouis/sponsored/Section?oid=33881280" target="_self">Sponsored Articles</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/stlouis/reeferfront-times/Section?oid=35262379" 
               target="_">
              Reeferfront Times
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/stlouis/reeferfront-times/Section?oid=35262379" target="_self">Reeferfront Times</a></li>
          
            <li><a href="/blogs/WeedNews/" target="_self">Weed News</a></li>
          
            <li><a href="/stlouis/dispensary-reviews/Category?oid=35262629" target="_self">Dispensary Reviews</a></li>
          
            <li><a href="/stlouis/LocationSearch?locationSection=35262377&sortType=name" target="_self">Dispensary Directory</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/stlouis/joblistings/Page" 
               target="_">
              Classifieds
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/stlouis/joblistings/Page" target="_self">Job Listings</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>Social Media</h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="https://www.facebook.com/riverfronttimes" target="_blank">Facebook</a></li>
          
            <li><a href="https://twitter.com/riverfronttimes/" target="_blank">Twitter</a></li>
          
            <li><a href="https://instagram.com/riverfronttimes/" target="_blank">Instagram</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/stlouis/AboutRiverfrontTimes/Page" 
               target="_">
              About Riverfront Times
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/stlouis/AboutRiverfrontTimes/Page" target="_self">About</a></li>
          
            <li><a href="/stlouis/AdvertiseWithRiverfrontTimes/Page" target="_self">Advertising Info</a></li>
          
            <li><a href="/stlouis/ContactUs/Page" target="_self">Contact Us</a></li>
          
            <li><a href="/stlouis/Jobs/Page" target="_self">Jobs</a></li>
          
            <li><a href="/stlouis/Newsletters/Page" target="_self">Subscribe</a></li>
          
            <li><a href="/stlouis/Newsletters/Page" target="_self">Newsletters</a></li>
          
            <li><a href="/stlouis/Policies/Page" target="_self">Policies</a></li>
          
        </ul>

      </div>
    

  </div><!-- End .linkGroupColumn -->
</div>
<!-- End #FooterNavigation -->

















<style>
.sister-links {
  padding: 1em 0;
  border-top: 1px solid #ccc;
}
.sister-links h3 {
  text-align: center;
  font-size: 16px;
}
.sister-links h4 {
  text-align: center;
  font-size: 12px;
  text-transform:uppercase
}
.sister-links p {
  text-align: center;
  font-size: 12px;
}
.sister-links ul {
  text-align: center;
  display: flex;
  flex-wrap: wrap;
  margin: 10px auto;
  justify-content: center;
}
.sister-links li {
  text-align: center;
  padding: 5px 1em;
  border-right: 1px solid #ccc;
}
.sister-links li:last-child {
  border-right:none;
}
</style>

<div id="sister-links" class="sister-links">
  <h3>Euclid Media Group, LLC</h3>
  <h4>Read Our Sister Publications </h4>
  <ul>
    
      
        <li>
          <a href="https://www.clevescene.com/" rel="noreferrer" target="_blank" heap-ignore="true">
            Cleveland Scene
          </a>
        </li>
      
    
      
        <li>
          <a href="https://www.citybeat.com/" rel="noreferrer" target="_blank" heap-ignore="true">
            Cincinnati CityBeat
          </a>
        </li>
      
    
      
        <li>
          <a href="https://www.cltampa.com/" rel="noreferrer" target="_blank" heap-ignore="true">
            Creative Loafing Tampa
          </a>
        </li>
      
    
      
        <li>
          <a href="https://www.metrotimes.com/" rel="noreferrer" target="_blank" heap-ignore="true">
            Detroit Metro Times
          </a>
        </li>
      
    
      
        <li>
          <a href="https://www.leoweekly.com/" rel="noreferrer" target="_blank" heap-ignore="true">
            Louisville LEO Weekly
          </a>
        </li>
      
    
      
        <li>
          <a href="https://www.orlandoweekly.com/" rel="noreferrer" target="_blank" heap-ignore="true">
            Orlando Weekly
          </a>
        </li>
      
    
      
    
      
        <li>
          <a href="https://www.sacurrent.com/" rel="noreferrer" target="_blank" heap-ignore="true">
            San Antonio Current
          </a>
        </li>
      
    
      
        <li>
          <a href="https://outinsa.com/" rel="noreferrer" target="_blank" heap-ignore="true">
            Out in SA
          </a>
        </li>
      
    
      
        <li>
          <a href="https://outinstl.com/" rel="noreferrer" target="_blank" heap-ignore="true">
            Out in STL
          </a>
        </li>
      
    
  </ul>
  <h4>Marketing Services</h4>
  <p>
    <a href="https://localculturecreative.com/" target="_blank" heap-ignore="true">
      Local Culture Creative
    </a>
  </p>
</div>
<div id="footerCopyright">
  <p>
   &copy; 2021
   <a href="/stlouis/ContactUs/Page">Riverfront Times</a> 
   <br><br>
   Website powered by <a href="https://www.publishwithfoundation.com/" target="_blank">Foundation</a>
  </p>
</div><!-- Active Campaign -->
<script type="text/javascript">
  (function(e,t,o,n,p,r,i){e.visitorGlobalObjectAlias=n;e[e.visitorGlobalObjectAlias]=e[e.visitorGlobalObjectAlias]||function(){(e[e.visitorGlobalObjectAlias].q=e[e.visitorGlobalObjectAlias].q||[]).push(arguments)};e[e.visitorGlobalObjectAlias].l=(new Date).getTime();r=t.createElement("script");r.src=o;r.async=true;i=t.getElementsByTagName("script")[0];i.parentNode.insertBefore(r,i)})(window,document,"https://diffuser-cdn.app-us1.com/diffuser/diffuser.js","vgo");
  vgo('setAccount', '26668640');
  vgo('setTrackByDefault', true);

  vgo('process');
</script>


  <img src="/foundation/images/icons/pixel.gif?oid=36544591" alt="" />


    </div><!-- end gridFooter -->

  </div><!-- end gridMain -->

</div><!-- end gridClamp -->

<!-- Closer -->
<div id="gridCloser">
  <div id="AdReskin" class="Closer BlogPost ">
  <!-- /43707298/STL_Reskin -->
          <div id="div-gpt-ad-stl_reskin" style="" data-content-type="ad" data-slot="/43707298/STL_Reskin" data-output="asynchronous" data-width="" data-height="">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-stl_reskin');
                });
              </script>
          </div>
</div>
<script>
    var pageInfo = {
      article: true,
      post_id: "https://www.riverfronttimes.com/newsblog/2021/11/04/st-louis-city-joins-forces-with-local-schools-to-vaccinate-kids-against-covid-19",
      post_type: "Blog",
      // resource_ref: unique_reference_string, // optional
      taxonomies: {
        tags: ["St. Louis news", "St. Louis", "Missouri", "pediatric covid vaccine", "COVID-19 vaccine", "where to get kids covid vaccine", "St. Louis Public Schools"],
        vertical: ["news"],
        category: ["newsblog"]
      },
      url: window.location.href
    };
    window.pico('visit', pageInfo);
    </script>
</div><!-- end gridCloser -->
    </body>
</html>
  


