
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "https://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="https://www.w3.org/1999/xhtml" xmlns:fb="https://www.facebook.com/2008/fbml" xml:lang="en" lang="en">
<head>
<meta name="viewport" content="width=1000">
<meta name="layout" content="Content Default" />
<meta name="oid" content="37218033" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta http-equiv="imagetoolbar" content="no" />
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=c1eb0a04456be9846248b6ba6270fa90" />
<link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=c1eb0a04456be9846248b6ba6270fa90" />
<link rel="stylesheet" type="text/css" href="/styles/components.css?cb=c1eb0a04456be9846248b6ba6270fa90" />
<link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=c1eb0a04456be9846248b6ba6270fa90" />
<script src="/foundation/fontawesome/js/brands.min.js" async></script>
<script src="/foundation/fontawesome/js/solid.min.js" async></script>
<script src="/foundation/fontawesome/js/regular.min.js" async></script>
<script src="/foundation/fontawesome/js/fontawesome.min.js" async></script>
<script src="/foundation/fontawesome/js/light.min.js" async></script>
<script src="/foundation/fontawesome/js/duotone.min.js" async></script>
<style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>
<link rel="stylesheet" type="text/css" href="/foundation/grids/iapetus-10-zone.css" />
<!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
<!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
<!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
<!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->
<link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />
<link rel="alternate" type="application/rss+xml" title="Riverfront Times RSS: Whole Site" href="https://www.riverfronttimes.com/stlouis/Rss.xml" />
<link rel="alternate" type="application/rss+xml" title="Riverfront Times RSS: Music Section" href="https://www.riverfronttimes.com/stlouis/Rss.xml?oid=2348804" />
<link rel="alternate" type="application/rss+xml" title="Riverfront Times RSS: Music News &amp; Interviews" href="https://www.riverfronttimes.com/stlouis/Rss.xml?oid=2349233" />
<link rel="alternate" type="application/rss+xml" title="Riverfront Times RSS: Comments on Snoop Dogg Is Playing the Family Arena and, Yes, You're Old" href="https://www.riverfronttimes.com/stlouis/Rss.xml?id=comments&amp;oid=37218033" />
<script>window.__FBAPIv__ = 'v3.2'</script>
<!--[if lte IE 8]>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
      <![endif]-->
<script>
        if (!window.Promise) document.write('<scr'+'ipt src="https://cdnjs.cloudflare.com/ajax/libs/native-promise-only/0.8.1/npo.src.js"></scr'+'ipt>')
      </script>

<script src="/foundation/scripts/common.js?cb=dbb2811e461474f60721203507ce57c6"></script>
<script src="/foundation/scripts/desktop-bundle.js?cb=dbb2811e461474f60721203507ce57c6"></script>
<link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
<script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>
<script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("https:\/\/www.riverfronttimes.com\/stlouis\/Profile", "https:\/\/posting.riverfronttimes.com\/stlouis\/MyProfile");
  </script>
<meta name="google-signin-client_id" content="87938396824-n9je30of0amajur33q7mm972pi0k5oc8.apps.googleusercontent.com">

<script type="text/javascript" async=true>
  (function() {
    var host = window.location.hostname;
    var element = document.createElement('script');
    var firstScript = document.getElementsByTagName('script')[0];
    var url = 'https://quantcast.mgr.consensu.org'
      .concat('/choice/', 'ECpz7gxYXdCG2', '/', host, '/choice.js')
    var uspTries = 0;
    var uspTriesLimit = 3;
    element.async = true;
    element.type = 'text/javascript';
    element.src = url;

    firstScript.parentNode.insertBefore(element, firstScript);

    function makeStub() {
      var TCF_LOCATOR_NAME = '__tcfapiLocator';
      var queue = [];
      var win = window;
      var cmpFrame;

      function addFrame() {
        var doc = win.document;
        var otherCMP = !!(win.frames[TCF_LOCATOR_NAME]);

        if (!otherCMP) {
          if (doc.body) {
            var iframe = doc.createElement('iframe');

            iframe.style.cssText = 'display:none';
            iframe.name = TCF_LOCATOR_NAME;
            doc.body.appendChild(iframe);
          } else {
            setTimeout(addFrame, 5);
          }
        }
        return !otherCMP;
      }

      function tcfAPIHandler() {
        var gdprApplies;
        var args = arguments;

        if (!args.length) {
          return queue;
        } else if (args[0] === 'setGdprApplies') {
          if (
            args.length > 3 &&
            args[2] === 2 &&
            typeof args[3] === 'boolean'
          ) {
            gdprApplies = args[3];
            if (typeof args[2] === 'function') {
              args[2]('set', true);
            }
          }
        } else if (args[0] === 'ping') {
          var retr = {
            gdprApplies: gdprApplies,
            cmpLoaded: false,
            cmpStatus: 'stub'
          };

          if (typeof args[2] === 'function') {
            args[2](retr);
          }
        } else {
          queue.push(args);
        }
      }

      function postMessageEventHandler(event) {
        var msgIsString = typeof event.data === 'string';
        var json = {};

        try {
          if (msgIsString) {
            json = JSON.parse(event.data);
          } else {
            json = event.data;
          }
        } catch (ignore) {}

        var payload = json.__tcfapiCall;

        if (payload) {
          window.__tcfapi(
            payload.command,
            payload.version,
            function(retValue, success) {
              var returnMsg = {
                __tcfapiReturn: {
                  returnValue: retValue,
                  success: success,
                  callId: payload.callId
                }
              };
              if (msgIsString) {
                returnMsg = JSON.stringify(returnMsg);
              }
              event.source.postMessage(returnMsg, '*');
            },
            payload.parameter
          );
        }
      }

      while (win) {
        try {
          if (win.frames[TCF_LOCATOR_NAME]) {
            cmpFrame = win;
            break;
          }
        } catch (ignore) {}

        if (win === window.top) {
          break;
        }
        win = win.parent;
      }
      if (!cmpFrame) {
        addFrame();
        win.__tcfapi = tcfAPIHandler;
        win.addEventListener('message', postMessageEventHandler, false);
      }
    };

    makeStub();

    var uspStubFunction = function() {
      var arg = arguments;
      if (typeof window.__uspapi !== uspStubFunction) {
        setTimeout(function() {
          if (typeof window.__uspapi !== 'undefined') {
            window.__uspapi.apply(window.__uspapi, arg);
          }
        }, 500);
      }
    };

    var checkIfUspIsReady = function() {
      uspTries++;
      if (window.__uspapi === uspStubFunction && uspTries < uspTriesLimit) {
        console.warn('USP is not accessible');
      } else {
        clearInterval(uspInterval);
      }
    };

    if (typeof window.__uspapi === 'undefined') {
      window.__uspapi = uspStubFunction;
      var uspInterval = setInterval(checkIfUspIsReady, 6000);
    }
  })();
  </script>


<style>
    .ccpaNotice {
      clear: both;
      border: 2px solid #D0D1D3;
      padding: 13px;
      font-size: 16px;
    }
  </style>
<script>
  if (typeof window.__uspapi === 'function') {
    window.__uspapi('uspPing', 1, function(obj, status) {
      if (status && obj.mode.includes('USP') && obj.jurisdiction.includes(obj.location.toUpperCase())) {
        var message = document.createElement("p");
        message.setAttribute("class", "ccpaNotice");
        message.innerHTML = 'Our website uses technical, analytical, marketing, and preference cookies to provide the best experience for our readers and to give us information about how our site is used. You may request that your data not be shared with third parties here: ' 
          + `<a href="#" onclick="window.__uspapi('displayUspUi');"` 
          + '>Do Not Sell My Data</a>' 
          + '.';
        document.getElementById('gridFooter').append(message);
        window.__uspapi('setUspDftData', 1, function(obj, status) {
          if (!status) {
              console.log("Error: USP string not updated!")
          }
        });
     }
    });
  }
  </script>

<meta name="google-site-verification" content="t27RxzckhbflL78fSWUcvc_CarJTRS3UpdhCJHd8pCI" />
<meta name='msvalidate.01' content='3443F17DFB93961891E95B1452B50579' />
<meta name='pocket-site-verification' content='b1bd6d10226d722c350fdb32758f53' />
<link href='https://plus.google.com/113763785405995504983' rel='publisher' />

<meta name="google-site-verification" content="yW0a7N25x35btonU2z_kSz5V6UlPpd8RdziyVGaAudk" />

<link href='https://fonts.googleapis.com/css?family=Lato:400,700|Titillium+Web:400,700|Montserrat:400,700' rel='stylesheet' type='text/css'>


<link rel="preconnect" href="https://fonts.googleapis.com">
<link rel="preconnect" href="https://fonts.gstatic.com" crossorigin>
<link href="https://fonts.googleapis.com/css2?family=Lato:wght@400;700&family=Montserrat:wght@400;700&family=Open+Sans+Condensed:wght@300;700&family=Titillium+Web:wght@400;700&display=swap" rel="stylesheet">

<style>
:root {
 --pub-primary-color:#31639C;
 --pub-link-color:#31639C;
  --real-1-primary-color: #31639C;
  --real-1-secondary-color: #31639C66;
}
</style>
<script type='text/javascript'>
            var googletag = googletag || {};
            googletag.cmd = googletag.cmd || [];
            (function() {
              var gads = document.createElement('script');
              gads.async = true;
              gads.type = 'text/javascript';
              var useSSL = 'https:' == document.location.protocol;
              gads.src = (useSSL ? 'https:' : 'http:') + '//securepubads.g.doubleclick.net/tag/js/gpt.js';
              var node = document.getElementsByTagName('script')[0];
              node.parentNode.insertBefore(gads, node);
            })();
          </script>
<script type='text/javascript'>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</script>

<script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

    //
    ga('create', 'UA-67359815-1', 'riverfronttimes.com');
    ga('set', 'anonymizeIp', true);
    ga('send', 'pageview', { 'dimension1': 'music', 'dimension2': 'music' });
    </script>

<script>
  var Euclid = Euclid || {}
  Euclid.RiverFrontTimes = Euclid.RiverFrontTimes || {}
  Euclid.RiverFrontTimes.vertical = Euclid.RiverFrontTimes.vertical || 'music'
  </script>
<script>
  (function() {
  if(document.getElementById('commitchange-script')) return;
  var npo = 5488;
  var script = document.createElement('script');
  var first = document.getElementsByTagName('script')[0];
  script.setAttribute('data-npo-id', npo);
  script.id = 'commitchange-script';
  script.src = 'https://us.commitchange.com/js/donate-button.v2.js';
  first.parentNode.insertBefore(script, first);
  })();
  </script>
<style>
:root {
 --pub-primary-color:#31639C;
 --pub-link-color:#31639C;
}
</style>
<link rel="shortcut icon" href="/favicon.ico" />
<meta name="title" content="Snoop Dogg Is Playing the Family Arena and, Yes, You&#39;re Old | Music News &amp; Interviews | St. Louis | St. Louis News and Events | Riverfront Times" />
<meta name="description" content="If you didn&rsquo;t already figure it out when the music of your generation was featured on the Super Bowl halftime show in medley form: You&rsquo;re..." />
<meta name="keywords" content="St. Louis, news, St. Louis news, Missouri, St. Charles, Family Arena, Snoop Dogg, Warren G, Super Bowl, concert, performance, show, St. Louis news, MO news, St. Louis events, MO events, Riverfront Times" />
<title>Snoop Dogg Is Playing the Family Arena and, Yes, You're Old | Music News & Interviews | St. Louis | St. Louis News and Events | Riverfront Times</title>
<meta name="date" content="2022-02-22 11:08:00" />
<meta name="author" content="Jaime Lees">
<meta name="news_keywords" content="st louis, news, st louis news, missouri, st charles, family arena, snoop dogg, warren g, super bowl, concert" />
<link rel="image_src" href="https://media2.riverfronttimes.com/riverfronttimes/imager/u/slideshow/37218270/33-snoop-dogg.jpg" />
<meta name="thumbnail" content="https://media2.riverfronttimes.com/riverfronttimes/imager/u/slideshow/37218270/33-snoop-dogg.jpg" />
<link rel="canonical" href="https://www.riverfronttimes.com/stlouis/snoop-dogg-is-playing-the-family-arena-and-yes-youre-old/Content?oid=37218033" />
<link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.riverfronttimes.com/stlouis/snoop-dogg-is-playing-the-family-arena-and-yes-youre-old/Content?oid=37218033" />
<link rel="amphtml" href="https://www.riverfronttimes.com/stlouis/snoop-dogg-is-playing-the-family-arena-and-yes-youre-old/Content?oid=37218033&media=AMP+HTML" />
<meta property="og:url" content="https://www.riverfronttimes.com/stlouis/snoop-dogg-is-playing-the-family-arena-and-yes-youre-old/Content?oid=37218033" />
<meta property="fb:app_id" content="1429692410383325" />
<meta property="og:site_name" content="Riverfront Times" />
<meta property="og:title" content="Snoop Dogg Is Playing the Family Arena and, Yes, You&#39;re Old" />
<meta property="og:image" content="https://media2.riverfronttimes.com/riverfronttimes/imager/u/slideshow/37218270/33-snoop-dogg.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="337" />
<meta property="og:description" content="If you didn&rsquo;t already figure it out when the music of your generation was featured on the Super Bowl halftime show in medley form: You&rsquo;re..." />
<meta property="og:type" content="article" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:image" content="https://media2.riverfronttimes.com/riverfronttimes/imager/u/slideshow/37218270/33-snoop-dogg.jpg">
<meta name="twitter:site" content="@riverfronttimes/">
<meta name="twitter:title" content="Snoop Dogg Is Playing the Family Arena and, Yes, You&#39;re Old">
<meta name="twitter:description" content="If you didn&rsquo;t already figure it out when the music of your generation was featured on the Super Bowl halftime show in medley form: You&rsquo;re...">

<script type="application/ld+json">
          {
            "mainEntityOfPage": {
              "@type": "WebPage",
              "@id":"https:\/\/www.riverfronttimes.com\/stlouis\/snoop-dogg-is-playing-the-family-arena-and-yes-youre-old\/Content?oid=37218033"
            },
            "headline": "Snoop Dogg Is Playing the Family Arena and, Yes, You're Old",
            
              "description": "If you didn’t already figure it out when the music of your generation was featured on the Super Bowl halftime show in medley form: You’re old. Yep, bad news for Gen X and millennials just keeps coming.",
            
            "image": {
              "url": "https:\/\/media2.riverfronttimes.com\/riverfronttimes\/imager\/u\/original\/37218270\/33-snoop-dogg.jpg",
              "width": 660,
              "height": 371,
              "@type": "ImageObject"
            },
            "datePublished": "2022-02-22T11:08:00",
            "dateModified": "2022-02-22T15:33:10",
            
              
              "author": {
                "name": "Jaime Lees",
                "url": "https:\/\/www.riverfronttimes.com\/author\/jaime-lees",
                "@type": "Person"
              },
            
            "publisher": {
              "name": "Riverfront Times",
              
                
                
                
                "logo": {
                  "url": "https:\/\/www.riverfronttimes.com\/imager\/b\/google-amp-logo\/808579\/2a75\/riverfront_fb.png",
                  "width": 60,
                  "height": 60,
                  "@type": "ImageObject"
                },
              
              "@type": "Organization"
            },
            "@context": "https://schema.org",
            "@type": "NewsArticle"
          }
        </script>
</head>
<body id="Content" class="ContentDefault Iapetus10Zone music musicstories">

<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-W5SPSS"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-W5SPSS');</script>

<div id="fb-root"></div>
<script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>
<script>
    (function () {
      var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
        //if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
      }.bind(this), function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
      })
    })()
  </script>

<div id="gridLeader">
<div id="AdInterstitial" class="Leader ContentDefault ">

<div id="div-gpt-ad-stl_desktopinterstitial" style="" data-content-type="ad" data-slot="/43707298/STL_DesktopInterstitial" data-output="asynchronous" data-width="" data-height="">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-stl_desktopinterstitial');
                });
              </script>
</div>
</div>
<style>
      /*-- desktop styles --*/
       #AdBackground {top:50px!important;}
      .nominate-bar {
          background:#91114f;
          z-index: 1;
          overflow:hidden;
          width: 100%;
          padding: 0;
          text-transform: uppercase;
          text-align: center;
          color: #fff;
          font-size: 18px;
      }
      .nominate-bar div {
      	border: 1px solid #ffffff;
          margin: 5px auto;
          max-width: 1000px;
      }
      .nominate-bar a {
      	color:#fff;
      }
  /* Adjust the ad positioning */
  body {
    background-position-y: 39px !important;
  }

      </style>
<div class="nominate-bar">
<div>
<p><a href="https://www.riverfronttimes.com/stlouis/SupportLocalJournalism/Page" target="_new">Support Local Journalism. Join Riverfront Times Press Club.</a></p>
</div>
</div>
</div>
<div id="gridClamp">

<div id="gridHeader">
<div id="MobileDetect" class="GlobalHeader ContentDefault " style="display:none">
Switch to the <a href="https://m.riverfronttimes.com/stlouis/snoop-dogg-is-playing-the-family-arena-and-yes-youre-old/Content?oid=37218033" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
</div>
<script>
      
      function setRedirectHash() {
        if (location.hash) {
          jQuery("#MobileDetect a[media='handheld']").each(function() {
            var link = jQuery(this);
            link.attr('href', link.attr('href').split('#')[0] + location.hash);
          });
        }
      }
      setRedirectHash();

      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
<div id="LogoHeader" class="GlobalHeader ContentDefault ">
<div id="logoLeft">
<a href="https://www.riverfronttimes.com/" title="St. Louis Riverfront Times">St. Louis Riverfront Times</a>
</div>
<div id="leaderboardAdHeader">

<div id="div-gpt-ad-stl_728x90-1" style="" data-content-type="ad" data-slot="/43707298/STL_728x90" data-output="asynchronous" data-width="728" data-height="90">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-stl_728x90-1');
                });
              </script>
</div>
</div>
</div>

<div id="NavigationHorizontal" class="GlobalHeader ContentDefault  ">
<ul id="mainNav">
<li class="first" id="NavItem_News">
<a href="https://www.riverfronttimes.com/stlouis/news/Section?oid=2348800" class="subnav_link" id="SNAVL_News">News</a>
</li>
<li class="" id="NavItem_ArtsCulture">
<a href="https://www.riverfronttimes.com/stlouis/arts-and-culture/Section?oid=2348805" class="subnav_link" id="SNAVL_ArtsCulture">Arts &amp; Culture</a>
</li>
<li class="" id="NavItem_fooddrink">
<a href="https://www.riverfronttimes.com/stlouis/food-drink/Section?oid=2348803" class="subnav_link" id="SNAVL_fooddrink">Food &amp; Drink</a>
</li>
<li class="navCurrent" id="NavItem_Music">
<a href="https://www.riverfronttimes.com/stlouis/music/Section?oid=2348804" class="subnav_link" id="SNAVL_Music">Music</a>
</li>
<li class="" id="NavItem_Film">
<a href="https://www.riverfronttimes.com/stlouis/movies/Section?oid=2348802" class="subnav_link" id="SNAVL_Film">Movies</a>
</li>
<li class="" id="NavItem_ReeferfrontTimes">
<a href="https://www.riverfronttimes.com/stlouis/reeferfront-times/Section?oid=35262379" class="subnav_link" id="SNAVL_ReeferfrontTimes">Reeferfront Times</a>
</li>
<li class="" id="NavItem_Calendar">
<a href="https://www.riverfronttimes.com/stlouis/EventSearch" class="subnav_link" id="SNAVL_Calendar">Calendar</a>
</li>

<li class="" id="NavItem_bestof">
<a href="https://www.riverfronttimes.com/stlouis/BestOf" class="subnav_link" id="SNAVL_bestof">Best Of</a>
</li>
<li class="" id="NavItem_Slideshows">
<a href="http://photos.riverfronttimes.com">Slideshows</a>
</li>
<li class="" id="NavItem_Support">
<a href="https://www.riverfronttimes.com/stlouis/SupportLocalJournalism/Page" class="subnav_link" id="SNAVL_Support">Support</a>
</li>
<li class="last" id="NavItem_Advertise">
<a href="https://www.riverfronttimes.com/stlouis/AdvertiseWithRiverfrontTimes/Page">Advertise</a>
</li>
</ul>
<h3 class="hidden">Browse News</h3>
<ul class="subnav_content" id="SNAV_News" style="display:none;">
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/st-louis-metro-news/Category?oid=2349235" title="">St. Louis Metro News</a>
</li>
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/missouri-news/Category?oid=37051540" title="">Missouri News</a>
</li>
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/hartmann/Category?oid=2349242" title="">Hartmann</a>
</li>
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/IssueArchives?issue=thisweek" title="">Digital Issue</a>
</li>
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/ArticleArchives?keywords=&section=2348807&category=&sortType=release" title="">St. Louis Guides</a>
</li>
<li class="">
<a href="https://photos.riverfronttimes.com/category/newsslideshows/?slide=1" title="">News Slideshows</a>
</li>
</ul>
<h3 class="hidden">Browse Arts &amp; Culture</h3>
<ul class="subnav_content" id="SNAV_ArtsCulture" style="display:none;">
<li class="">
<a href="https://photos.riverfronttimes.com/category/artsslideshows/" title="">Arts &amp; Culture Slideshows</a>
</li>
</ul>
<h3 class="hidden">Browse Food &amp; Drink</h3>
<ul class="subnav_content" id="SNAV_fooddrink" style="display:none;">
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/LocationSearch?locationSection=2683245&sortType=name" title="">Find a Restaurant</a>
</li>
<li class="">
<a href="https://photos.riverfronttimes.com/category/foodslideshows/?slide=1" title="">Food &amp; Drink Slideshows</a>
</li>
</ul>
<h3 class="hidden">Browse Music</h3>
<ul class="subnav_content" id="SNAV_Music" style="display:none;">
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/EventSearch?eventCategory=2960217&sortType=date&v=d" title="">Find a Concert</a>
</li>
<li class="">
<a href="https://photos.riverfronttimes.com/category/musicslideshows/" title="">Music Slideshows</a>
</li>
</ul>
<h3 class="hidden">Browse Movies</h3>
<ul class="subnav_content" id="SNAV_Film" style="display:none;">
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/movie-reviews-and-news/Category?oid=2349243" title="">Movie Reviews &amp; News</a>
</li>
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/MovieTimes" title="">Movie Times</a>
</li>
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/LocationSearch?locationCategory=2683256&sortType=name" title="">Find a Theater</a>
</li>
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/FreeStuff" title="">Giveaways</a>
</li>
</ul>
<h3 class="hidden">Browse Calendar</h3>
<ul class="subnav_content" id="SNAV_Calendar" style="display:none;">
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/EventSearch?narrowByDate=Today" title="">Today&#39;s Events</a>
</li>
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/EventSearch?narrowByDate=This%20Weekend" title="">This Weekend</a>
</li>
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/EventSearch?eventCategory=2759675&sortType=date&v=d" title="">Free Events</a>
</li>
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/Events/AddEvent" title="">Submit an Event</a>
</li>
</ul>
<h3 class="hidden">Browse Support</h3>
<ul class="subnav_content" id="SNAV_Support" style="display:none;">
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/SupportLocalJournalism/Page" title="">Donate</a>
</li>
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/Newsletters/Page" title="">Subscribe</a>
</li>
<li class="">
<a href="https://shop.euclidmediagroup.com/collections/riverfront-times" target="_blank" title="">Shop RFT</a>
</li>
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/AdvertiseWithRiverfrontTimes/Page" title="">Advertise</a>
</li>
<li class="">
<a href="https://www.facebook.com/riverfronttimes" target="_blank" title="">Facebook</a>
</li>
<li class="">
<a href="https://twitter.com/riverfronttimes/" target="_blank" title="">Twitter</a>
</li>
<li class="">
<a href="https://instagram.com/riverfronttimes/" target="_blank" title="">Instagram</a>
</li>
</ul>
<h3 class="hidden">Browse Best Of</h3>
<ul class="subnav_content" id="SNAV_bestof" style="display:none;">
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/arts-and-entertainment/BestOf?category=2349229" title="">Arts &amp; Entertainment</a>
</li>
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/food-and-drink/BestOf?category=2349230" title="">Food &amp; Drink</a>
</li>
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/people-and-places/BestOf?category=2349227" title="">People &amp; Places</a>
</li>
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/sports-and-recreation/BestOf?category=2349228" title="">Sports &amp; Recreation</a>
</li>
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/goods-and-services/BestOf?category=2349244" title="">Goods &amp; Services</a>
</li>
</ul>
<h3 class="hidden">Browse Reeferfront Times</h3>
<ul class="subnav_content" id="SNAV_ReeferfrontTimes" style="display:none;">
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/weed-news/Category?oid=35262620" title="">Weed News</a>
</li>
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/dispensary-reviews/Category?oid=35262629" title="">Dispensary Reviews</a>
</li>
<li class="">
<a href="https://www.riverfronttimes.com/stlouis/LocationSearch?locationSection=35262377&sortType=name" title="">Dispensary Directory</a>
</li>
</ul>
</div>
<script>
      "use strict";
      (function(){
        //
        if(navigator.userAgent.match(/\b(iPad|iPhone|iPod|Android|Pre|BlackBerry|Windows Phone)\b/i)){
          //
          //
            jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
          //
          //

        //
        }else{
          jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
        }
      })();
      </script>

<div id="AdPencilBar" class="GlobalHeader ContentDefault ">

<div id="div-gpt-ad-stl_970x90" style="" data-content-type="ad" data-slot="/43707298/STL_970x90" data-output="asynchronous" data-width="970" data-height="90">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-stl_970x90');
                });
              </script>
</div>
</div>
</div>
<div id="gridMain">
<div id="gridFrame">
<div id="gridSpanningFeature">
<div id="StoryBreadcrumb" class="SpanningFeature ContentDefault  music music_news___interviews">
<p class="issueInfo ">
<span class="date">
<a href="https://www.riverfronttimes.com/stlouis/IssueArchives?issue=37184555">February 22, 2022</a>
</span>
<a href="https://www.riverfronttimes.com/stlouis/music/Section?oid=2348804">Music</a>
&raquo; <a href="https://www.riverfronttimes.com/stlouis/ArticleArchives?category=2349233">Music News & Interviews</a>
</p>
</div> 
<style>
    div.l0.last div:first-child {float:right;}
  </style>
<div id="ToolBarHorizontal" class="SpanningFeature ContentDefault ">
<div style="width:100%; height: 20px;">
<div class="l0 first" style="width:20%; height: 20px; float:left;">
<fb:like href="https://www.riverfronttimes.com/stlouis/snoop-dogg-is-playing-the-family-arena-and-yes-youre-old/Content?oid=37218033" send="false" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="button_count"></fb:like></div> <div class="l0" style="width:20%; height: 20px; float:left;"><a href="https://twitter.com/share?url=https%3A//www.riverfronttimes.com/stlouis/snoop-dogg-is-playing-the-family-arena-and-yes-youre-old/Content%3Foid%3D37218033&text=Snoop%20Dogg%20Is%20Playing%20the%20Family%20Arena%20and%2C%20Yes%2C%20You%27re%20Old" class="twitter-share-button" data-count="none">Tweet</a>
<script>
  dnLoadScript("https://platform.twitter.com/widgets.js", true);
</script></div> <div class="l0" style="width:20%; height: 20px; float:left;">
<a class="emailAction" title="Email" href="https://posting.riverfronttimes.com/stlouis/Tools/EmailFriend?oid=37218033" rel="nofollow" target="_blank" onclick="popupWindow('popupEmailFriend', this.href, 400, 650, 400, 10); return false">Email</a>
</div> <div class="l0" style="width:20%; height: 20px; float:left;">
<a class="printAction" title="Print" href="https://www.riverfronttimes.com/stlouis/snoop-dogg-is-playing-the-family-arena-and-yes-youre-old/Content?mode=print&amp;oid=37218033" rel="nofollow" target="_blank">Print</a>
</div> <div class="l0 last" style="width:20%; height: 20px; float:right;">
<div class="addthis_toolbox addthis_default_style"><a href="https://www.addthis.com/bookmark.php?v=300&pubid=ra-55a583d7ad700c31" addthis:url="https://www.riverfronttimes.com/stlouis/snoop-dogg-is-playing-the-family-arena-and-yes-youre-old/Content?oid=37218033" addthis:title="Snoop Dogg Is Playing the Family Arena and, Yes, You're Old" addthis:description="" class="addthis_button_compact">Share</a></div>
<script type="text/javascript">
    dnLoadScript("https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-55a583d7ad700c31", true);
  </script>
</div>
</div>
</div>
<script type="text/javascript">
      Foundation.Tools.setup();
    </script>
<div id="StoryHeader" class="SpanningFeature ContentDefault   ">
<div class="storyHead">
<h1 class="headline headline-37218033">Snoop Dogg Is Playing the Family Arena and, Yes, You're Old&nbsp;</h1> 
<cite class="byline">
<span class="byAttribute">By</span> <a href="https://www.riverfronttimes.com/author/jaime-lees" rel="author">Jaime Lees</a>
</cite>
</div>
</div> 
<div id="StoryLayout" class="SpanningFeature ContentDefault ">
<div id="storyBody" class="page1">
<div class="contentImageCenter" style="overflow:hidden;"> <img src="https://media2.riverfronttimes.com/riverfronttimes/imager/u/blog/37218270/33-snoop-dogg.jpg?cb=1645551747" width="660" height="371" alt="Snoop played Loufest once, too - THEO WELLING" srcset="" /> <ul style="width:660px;overflow:hidden;margin-left:auto;margin-right:auto;"> <li class="imageCredit"> THEO WELLING </li> <li class="imageCaption"> Snoop played Loufest once, too </li> </ul> </div> <br>
If you didn’t already figure it out when the music of your generation was featured on the Super Bowl halftime show in medley form: You’re old.
<br>
<br>
Yep, bad news for Gen X and millennials just keeps coming. Not only are their looks slipping and their second divorces pending, but their favorite songs and artists are not just considered retro, but oldies.
<br><br>
<div class="inlineComponent AdNativeInline">
<div id="AdNativeInline" class="SpanningFeature AdNativeInline ">

<div id="div-gpt-ad-stl_desktopnative-2" style="" data-content-type="ad" data-slot="/43707298/STL_DesktopNative" data-output="asynchronous" data-width="" data-height="">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-stl_desktopnative-2');
                });
              </script>
</div>
</div>
</div>
<br>
<br>
For local music fans of a certain age, this point was drilled in when it was announced that Snoop Dogg and Warren G are scheduled to play the <b>Family Arena</b> <i>(2002 Arena Parkway)</i> in St. Charles.
<br>
<br>
The venue is known for hosting child-friendly and aging-friendly experiences. If you’re a fan of “an evening with” experiences or mature sit-down concert events, the Family Arena is the venue for you.
<br>
<br>
The Family Arena has hosted shows for younger audiences, for sure, but this is not one of them. This is going to be all moms and dads who had to hire a babysitter to get a night out on the town to relive their youth.
<br>
<br>
The show is happening on April 23 — just days after 4/20 — and there will surely be a lot of former wine moms there who are trying to graduate up to edibles.
<br>
<br>
Man, it does sound kind of awesome. Wine moms on edibles are party animals and they’re always wearing the best, most uncomfortable shoes that they end up taking off and carrying to their car as they exit barefoot because they <i>had</i> to dance.
<br>
<br>
If you want in on this excellent experience, <a href="https://www.ticketmaster.com/event/06005C52948F81AB" target="_blank">tickets to the concert</a> go on sale at Ticketmaster at 10 a.m. this Friday, February 25.
<br>
<br>
But if you’re a real OG, you’ll want to grab some <a href="https://www.ticketmaster.com/event/06005C52948F81AB" target="_blank">presale tickets</a>. Those go on sale at 10 a.m. this Thursday, February 24. Use the code <b>DROPIT</b>. That’s “drop it” as in “<a href="https://www.youtube.com/watch?v=RaCodgL9cvk" target="_blank">Drop It Like It's Hot</a>.” You should do that, too. Pretend be young while you still can, elder Snoop fans! The seasons are changing and your knees aren’t going to hold out much longer.
<br>
<br>
<i><br>
Email the author at <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="0e646f67636b20626b6b7d4e7c67786b7c687c61607a7a67636b7d206d6163">[email&#160;protected]</a></i>
<ul>
<li><a href="https://www.riverfronttimes.com/stlouis/Newsletters/Page/">Sign up</a> for our weekly newsletters to get the latest on the news, things to do and places to eat delivered right to your inbox.</li>
<li>Follow us on <a href="https://www.facebook.com/riverfronttimes">Facebook</a>, <a href="https://twitter.com/riverfronttimes/">Twitter</a>, <a href="https://www.instagram.com/riverfronttimes/">Instagram</a>, <a href="https://www.reddit.com/r/RiverfrontTimes/">Reddit</a>, <a href="https://news.google.com/publications/CAAiELxEU1xKRmkqN8s-dSFIAbEqFAgKIhC8RFNcSkZpKjfLPnUhSAGx">Google News</a>.</li>
</ul>
</div>
</div> 

<link rel="stylesheet" type="text/css" href="/fdn-system/assets/pub/styles/desktop.css?cb=88228062817adc654df8d74e378f27d1" />

<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script src="/fdn-system/assets/pub/scripts/uikit.min.js?cb=88228062817adc654df8d74e378f27d1"></script>
<script src="/fdn-system/assets/pub/scripts/uikit-icons-fdn.min.js?cb=88228062817adc654df8d74e378f27d1"></script>
<style>
    @media (min-width: 640px){
      div[id] .uk-child-width-1-3\@exs > * {
         width: calc(100% * 1 / 3.001);
      } 
    }
    #gridMainColumn .uk-width-1-2\@es {
      width: 50%;
    }

    #gridMainColumn .uk-child-width-auto\@exs > * {
      width: auto;
    }
    
    .uk-root {
      font-size: 14px;
    }
  </style>
<div id="DonationArticleWidget" class="SpanningFeature ContentDefault " style="background-color: rgba(250, 250, 153, 1); padding: 10px;">
<center><p><big><b>Support Local Journalism.</b></big><br>
<big><b>Join the <i>Riverfront Times</i> Press Club</b></big><br><br>
Local journalism is information. Information is power. And we believe <b>everyone</b> deserves access to accurate independent coverage of their community and state. Our readers helped us continue this coverage in 2020, and we are so grateful for the support.
<br><br>
Help us keep this coverage going in 2021. Whether it's a one-time acknowledgement of this article or an ongoing membership pledge, your support goes to local-based reporting from our small but mighty team.
<br><br>
<big><b><a href="https://trypico.com/riverfronttimes?short_code=vjzgr2zk">Join the Riverfront Times Club for as little as $5 a month.</a>
</b></big>
</center>
</div>

<div id="StoryTags" class="SpanningFeature ContentDefault ">
<p class="tags">Tags: <a href="/stlouis/ArticleArchives?category=2349233" rel="tag">Music News & Interviews</a>, <a href="/stlouis/ArticleArchives?tag=St.%20Louis" rel="tag">St. Louis</a>, <a href="/stlouis/ArticleArchives?tag=news" rel="tag">news</a>, <a href="/stlouis/ArticleArchives?tag=St.%20Louis%20news" rel="tag">St. Louis news</a>, <a href="/stlouis/ArticleArchives?tag=Missouri" rel="tag">Missouri</a>, <a href="/stlouis/ArticleArchives?tag=St.%20Charles" rel="tag">St. Charles</a>, <a href="/stlouis/ArticleArchives?tag=Family%20Arena" rel="tag">Family Arena</a>, <a href="/stlouis/ArticleArchives?tag=Snoop%20Dogg" rel="tag">Snoop Dogg</a>, <a href="/stlouis/ArticleArchives?tag=Warren%20G" rel="tag">Warren G</a>, <a href="/stlouis/ArticleArchives?tag=Super%20Bowl" rel="tag">Super Bowl</a>, <a href="/stlouis/ArticleArchives?tag=concert" rel="tag">concert</a>, <a href="/stlouis/ArticleArchives?tag=performance" rel="tag">performance</a>, <a href="/stlouis/ArticleArchives?tag=show" rel="tag">show</a></p>
</div> 
<div id="JumptoComments" class="SpanningFeature ContentDefault ">
<a href="#Disqus">Jump to comments</a>
</div>
<div id="PreviousNextInCategory" class="SpanningFeature ContentDefault ">
<div class="prevNext">
<a href="https://www.riverfronttimes.com/stlouis/the-lot-concert-series-to-take-over-the-big-top-in-grand-center/Content?oid=37133491" class="prev" title="previous">&laquo;&nbsp;The Lot Concert Series to Take Over the Big Top in Grand Center</a>
</div>
</div>
<div id="ArchiveLink" class="SpanningFeature ContentDefault ">
<p class="moreArticles">
<a href="https://www.riverfronttimes.com/stlouis/ArticleArchives?category=2349233">More Music News & Interviews &raquo;</a>
</p>
</div> 
<div class="uk-root">
<div class="componentGrid-TwoZones-Auto-Expand uk-root uk-width-1-1 uk-flex uk-flex-row uk-flex-wrap fdn-component-grid-row@m" uk-height-match data-component-grid-id="TopStoriesVideoPair">
<div class="uk-width-1-1 uk-width-auto@m uk-flex uk-flex-column uk-inline fdn-component-grid-zone">
<div class="ComponentZoneA Real1PlayerTrendingPairresponsive  trending-by-day uk-root fdn-margin-vert TrendingContentList comp-landing-trending" data-component-id="TrendingContentList">
<div class="fdn-component-header-block uk-margin ">
<h3 class="fdn-component-header-text uk-margin-remove ">
Trending
</h3>
</div>
<ul class="pres-ContentListHeadline uk-list uk-list-divider">
<li class="fdn-pres-item">
<a class="uk-flex uk-flex-top" href="https://www.riverfronttimes.com/stlouis/the-lot-concert-series-to-take-over-the-big-top-in-grand-center/Content?oid=37133491">
<p class="fdn-teaser-headline">
The Lot Concert Series to Take Over the Big Top in Grand Center
</p>
</a>
</li>
</ul>
</div>
</div>
<div class="uk-width-1-1 uk-width-expand@m uk-flex uk-flex-column uk-inline fdn-component-grid-zone">
<script src="https://www.voqally.com/hub/app/r.js?key=16fa797df65f83d4a5d14d36954afeff" async></script>
</div>
</div>
</div>
<div id="RelatedStories" class="SpanningFeature ContentDefault RelatedItem">
<h3><span class="headingText">Related Stories</span></h3>
<ul class="">
<li class="l0 storyItem">
<a href="https://www.riverfronttimes.com/stlouis/you-should-probably-plan-to-smoke-a-doobie-during-robert-plants-set-at-loufest/Content?oid=20341083&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RelatedStories">
<img src="https://media1.riverfronttimes.com/riverfronttimes/imager/u/bigsquare/20346185/robertplant3d.jpg" alt="You Should Probably Plan to Smoke a Doobie During Robert Plant&rsquo;s Set at LouFest" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/you-should-probably-plan-to-smoke-a-doobie-during-robert-plants-set-at-loufest/Content?oid=20341083&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RelatedStories">You Should Probably Plan to Smoke a Doobie During Robert Plant’s Set at LouFest</a>
</h4>
<div class="date"> Jun 19, 2018 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.riverfronttimes.com/stlouis/clownvis-tested-some-stoner-accessories-for-4-20-and-boy-did-he-get-high/Content?oid=17786441&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RelatedStories">
<img src="https://media1.riverfronttimes.com/riverfronttimes/imager/u/bigsquare/17786668/cbd05.jpg" alt="Clownvis Tested Some Stoner Accessories for 4/20 And Boy Did He Get High" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/clownvis-tested-some-stoner-accessories-for-4-20-and-boy-did-he-get-high/Content?oid=17786441&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RelatedStories">Clownvis Tested Some Stoner Accessories for 4/20 And Boy Did He Get High</a>
</h4>
<div class="date"> Apr 20, 2018 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.riverfronttimes.com/stlouis/heres-snoop-dogg-smoking-a-blunt-in-an-ozzie-smith-jersey-at-loufest/Content?oid=8036622&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RelatedStories">
<img src="https://media1.riverfronttimes.com/riverfronttimes/imager/u/bigsquare/8036623/33-snoop-dogg.jpg" alt="Here&#39;s Snoop Dogg Smoking a Blunt in an Ozzie Smith Jersey at LouFest" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/heres-snoop-dogg-smoking-a-blunt-in-an-ozzie-smith-jersey-at-loufest/Content?oid=8036622&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RelatedStories">Here's Snoop Dogg Smoking a Blunt in an Ozzie Smith Jersey at LouFest</a>
</h4>
<div class="date"> Sep 10, 2017 </div>
</li>
</ul>
</div>
<div id="AdNativeEndofArticle" class="SpanningFeature ContentDefault ">

<div id="div-gpt-ad-stl_desktopnative-3" style="" data-content-type="ad" data-slot="/43707298/STL_DesktopNative" data-output="asynchronous" data-width="" data-height="">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-stl_desktopnative-3');
                });
              </script>
</div>
</div>
<div id="RecentByTag" class="SpanningFeature ContentDefault ">
<h3 class="latestfood___drink_news">
<span class="headingText">
Speaking of...
</span>
</h3>
<ul class="moduleList">
<li class="l0 storyItem">
<a href="https://www.riverfronttimes.com/stlouis/soulard-coffee-garden-a-popular-neighborhood-gathering-spot-has-closed/Content?oid=37214009&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RecentByTag">
<img src="https://media2.riverfronttimes.com/riverfronttimes/imager/u/bigsquare/37214234/soulard_coffee.jpg" alt="Soulard Coffee Garden Has Closed" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/soulard-coffee-garden-a-popular-neighborhood-gathering-spot-has-closed/Content?oid=37214009&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RecentByTag">Soulard Coffee Garden Has Closed</a>
</h4>
<div class="date"> Feb 22, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.riverfronttimes.com/stlouis/a-mistake-killed-drug-sentencing-reform-in-missouri-its-still-dead/Content?oid=37162285&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RecentByTag">
<img src="https://media1.riverfronttimes.com/riverfronttimes/imager/u/bigsquare/37212437/img_6643_web.jpg" alt="A Mistake Killed Drug Sentencing Reform in Missouri. It&#39;s Still Dead" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/a-mistake-killed-drug-sentencing-reform-in-missouri-its-still-dead/Content?oid=37162285&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RecentByTag">A Mistake Killed Drug Sentencing Reform in Missouri. It's Still Dead</a>
</h4>
<div class="date"> Feb 21, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.riverfronttimes.com/stlouis/st-louis-county-may-remove-mask-mandate-at-end-of-month/Content?oid=37196393&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RecentByTag">
<img src="https://media1.riverfronttimes.com/riverfronttimes/imager/u/bigsquare/37197084/masks.jpg" alt="St. Louis County May Remove Mask Mandate at End of Month" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/st-louis-county-may-remove-mask-mandate-at-end-of-month/Content?oid=37196393&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=RecentByTag">St. Louis County May Remove Mask Mandate at End of Month</a>
</h4>
<div class="date"> Feb 18, 2022 </div>
</li>
<li class="l0 storyItem more">
<a href="https://www.riverfronttimes.com/stlouis/ArticleArchives?tag=St.%20Louis%7C%7Cnews%7C%7CSt.%20Louis%20news%7C%7CMissouri%7C%7CSt.%20Charles%7C%7CFamily%20Arena%7C%7CSnoop%20Dogg%7C%7CWarren%20G%7C%7CSuper%20Bowl%7C%7Cconcert%7C%7Cperformance%7C%7Cshow" class="more">More &raquo;</a>
</li>
</ul>
</div>
<div id="Disqus" class="SpanningFeature ContentDefault ">
<div id="disqus_thread"></div>
<script type="text/javascript">
      <!--
        var disqus_shortname = "riverfronttimes2";
        var disqus_identifier = "riverfronttimes:37218033";
        var disqus_url = "https://www.riverfronttimes.com/stlouis/snoop-dogg-is-playing-the-family-arena-and-yes-youre-old/Content?oid=37218033";
        var disqus_title = "Snoop Dogg Is Playing the Family Arena and, Yes, You're Old";
        (function() {
            var dsq = document.createElement("script"); dsq.type = "text/javascript"; dsq.async = true;
            dsq.src = "https://" + disqus_shortname + ".disqus.com/embed.js";
            (document.getElementsByTagName("head")[0] || document.getElementsByTagName("body")[0]).appendChild(dsq);
        })();
      // -->
      </script>
<noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
</div>
<div id="LatestInCategory" class="SpanningFeature ContentDefault ">
<h3 class="latestmusic_news___interviews"><span class="headingText">Latest in Music News & Interviews</span></h3>
<ul class="moduleList ui list grouped expanded">
<li class="l0 storyItem">
<a href="https://www.riverfronttimes.com/stlouis/the-lot-concert-series-to-take-over-the-big-top-in-grand-center/Content?oid=37133491&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=LatestInCategory">
<img src="https://media1.riverfronttimes.com/riverfronttimes/imager/u/bigsquare/37190890/del_mccoury_band_-_photo_full_band_2b-highrescropped.jpg" alt="The Lot Concert Series to Take Over the Big Top in Grand Center" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/the-lot-concert-series-to-take-over-the-big-top-in-grand-center/Content?oid=37133491&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=LatestInCategory">The Lot Concert Series to Take Over the Big Top in Grand Center</a>
</h4>
<div class="date"> Feb 17, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.riverfronttimes.com/stlouis/st-louis-kijani-eshe-and-nick-g-bring-the-heat-with-summer-22/Content?oid=37073634&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=LatestInCategory">
<img src="https://media1.riverfronttimes.com/riverfronttimes/imager/u/bigsquare/37073633/culture-01-e7a788f213d4521e.jpg" alt="St. Louis&#39; Kijani Eshe and Nick G Bring the Heat with &lt;i&gt;Summer 22&#39;&lt;/i&gt;" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/st-louis-kijani-eshe-and-nick-g-bring-the-heat-with-summer-22/Content?oid=37073634&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=LatestInCategory">St. Louis' Kijani Eshe and Nick G Bring the Heat with <i>Summer 22'</i></a>
</h4>
<div class="date"> Feb 4, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.riverfronttimes.com/stlouis/a-glimpse-of-many-futures-a-deep-dive-into-afrofuturism-stl/Content?oid=37031304&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=LatestInCategory">
<img src="https://media2.riverfronttimes.com/riverfronttimes/imager/u/bigsquare/37031306/culture-01.jpg" alt="A Glimpse of Many Futures: A Deep Dive into Afrofuturism STL" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/a-glimpse-of-many-futures-a-deep-dive-into-afrofuturism-stl/Content?oid=37031304&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=LatestInCategory">A Glimpse of Many Futures: A Deep Dive into Afrofuturism STL</a>
</h4>
<div class="date"> Jan 28, 2022 </div>
</li>
<li class="l0 storyItem more">
<a href="https://www.riverfronttimes.com/stlouis/ArticleArchives?category=2349233&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=LatestInCategory" class="more">More &raquo;</a>
</li>
</ul>
</div>
<div id="MorebyThisAuthorWrapper" class="SpanningFeature ContentDefault Wrapper">
<div id="MorebyThisAuthor" class="SpanningFeature ContentDefault ">
<h3><span class="headingText">More by Jaime Lees</span></h3>
<ul class="moduleList">
<li class="l0 storyItem">
<a href="https://www.riverfronttimes.com/stlouis/road-conditions-across-missouri-are-rapidly-deteriorating/Content?oid=37190437&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">
<img src="https://media2.riverfronttimes.com/riverfronttimes/imager/u/bigsquare/37191103/missouripreview.jpg" alt="Road Conditions Across Missouri are Rapidly Deteriorating" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/road-conditions-across-missouri-are-rapidly-deteriorating/Content?oid=37190437&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">Road Conditions Across Missouri are Rapidly Deteriorating</a>
</h4>
<div class="date"> Feb 17, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.riverfronttimes.com/stlouis/st-louis-meteorologists-warn-of-possibly-a-few-tornados-with-incoming-storm/Content?oid=37184348&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">
<img src="https://media1.riverfronttimes.com/riverfronttimes/imager/u/bigsquare/37186645/fewtornados.jpg" alt="St. Louis Meteorologists Warn of &ldquo;Possibly a Few Tornados&rdquo; With Incoming Storm" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/st-louis-meteorologists-warn-of-possibly-a-few-tornados-with-incoming-storm/Content?oid=37184348&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">St. Louis Meteorologists Warn of “Possibly a Few Tornados” With Incoming Storm</a>
</h4>
<div class="date"> Feb 16, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.riverfronttimes.com/stlouis/welcome-home-nikki-glaser-highlights-comedian-nikki-glasers-move-to-st-louis/Content?oid=37179226&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">
<img src="https://media1.riverfronttimes.com/riverfronttimes/imager/u/bigsquare/37179230/nikkihands.jpg" alt="&#39;Welcome Home Nikki Glaser?&#39; Highlights Comedian&#39;s Move to St. Louis" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/welcome-home-nikki-glaser-highlights-comedian-nikki-glasers-move-to-st-louis/Content?oid=37179226&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=MorebyThisAuthor">'Welcome Home Nikki Glaser?' Highlights Comedian's Move to St. Louis</a>
</h4>
<div class="date"> Feb 15, 2022 </div>
</li>
<li class="l0 storyItem more">
<a href="https://www.riverfronttimes.com/stlouis/ArticleArchives?author=2339155" class="more">More &raquo;</a>
</li>
</ul>
</div>
</div>

<div class="SpanningFeature ContentDefault   uk-root fdn-margin-vert FoundationNetwork comp-content-foundationnetwork" data-component-id="FoundationNetwork">
<div class="fdn-component-header-block uk-margin ">
<h3 class="fdn-component-header-text uk-margin-remove ">
<a class="fdn-component-header-link-text" href="http://hub.fdncms.com/hub/Home?section=music" target="_blank">
Trending in the Alternative Press
</a>
</h3>
</div>
<div fdn-trending-results>
<div class="uk-inline uk-height-medium uk-flex uk-flex-center uk-flex-middle">
<div uk-spinner></div>
</div>
<div style="display: none;" fdn-trending-results-container class="pres-ContentTileSquareBrief uk-grid uk-grid-small 
                    uk-child-width-1-3@exs uk-child-width-1-2" uk-grid="true" data-ev-presentation="ContentTileSquareBrief" uk-height-match=".fdn-pres-image">
</div>
<div style="display: none;" fdn-trending-result-item>
<a fdn-teaser-url class="uk-flex uk-flex-column fdn-decoration-remove" href="" target="_blank">
<div>
<p fdn-teaser-headline class="fdn-teaser-headline">
</p>
<div fdn-teaser-infoline class="fdn-teaser-infoline fdn-inline-split-list">
</div>
</div>
<div class="uk-margin-small-bottom uk-flex-first uk-inline">
<img fdn-teaser-image src="">
<div class="uk-overlay uk-overlay-primary uk-position-bottom uk-padding-xsmall">
<p fdn-site-name class="fdn-teaser-image-overlay-text uk-margin-remove">
</p>
</div>
</div>
</a>
</div>
</div>
<script>
      (function(){
        var ajaxUrl = 'https://www.hub.fdncms.com/gyrobase/Responsive/Hub/Trending.html'
        var params = { section: 'music' }
        var componenSelector = '[data-component-id="FoundationNetwork"]'
        var resultsContainerSelector = componenSelector + ' [fdn-trending-results]'

        var resultItemsContainerSelector = componenSelector + ' [fdn-trending-results-container]'
        var resultItemsContainerElement = jQuery(resultItemsContainerSelector)
        var resultItemsContainerClone = jQuery(resultItemsContainerSelector)
            .clone().attr('style','')
        resultItemsContainerElement.remove()

        var resultItemSelector = componenSelector +  ' [fdn-trending-result-item]'
        var resultItemElement = jQuery(resultItemSelector)
        var resultItemClone = jQuery(resultItemSelector)
            .clone().attr('style','')
        resultItemElement.remove()

        var requestError = function (data) {
          jQuery(componenSelector)
            .html('<!-- Unable to load trending results -->')
          console.log('Unable to load trending results:', data)
        }

        let sitesUsed = []

        var requestSuccess = function (data) {
          console.log(data)

          if(data.topTrending.length) {

            for ( let i=0; i < Math.min(3, data.topTrending.length); i++) {
              sitesUsed.push(data.topTrending[i].item.siteName)

              let itemClone = resultItemClone.clone()
              itemClone.find('[fdn-teaser-image]')
                .attr('src', data.topTrending[i].item.imageUrl)
              itemClone.find('[fdn-site-name]')
                .text(data.topTrending[i].item.siteName)
              itemClone.find('[fdn-teaser-headline]')
                .html(data.topTrending[i].item.teaserHeadline)
              itemClone.find('[fdn-teaser-infoline]')
                .html(data.topTrending[i].item.teaserInfoline)
              itemClone.find('[fdn-teaser-url]')
                .attr('href', data.topTrending[i].item.teaserUrl)

              itemClone.appendTo(resultItemsContainerClone)
            }
          }

          if(data.trending.length) {
            let indexList = []
            let randomIndex = -1

            for (let i=0; i < data.trending.length; i++) {
              indexList.push(i)
            }

            // Get randos for the next 3 
            // 
            for (let i=0; i < Math.min(3, data.trending.length); i++) {
              // 
              do {
                randomIndex = indexList
                  .splice(Math.floor(Math.random() * indexList.length), 1)[0]
                console.log(randomIndex, indexList, data.trending[randomIndex].item.siteName)
              }
              while (randomIndex != undefined
                     && sitesUsed.indexOf(data.trending[randomIndex].item.siteName) != -1)

              // 
              if (randomIndex != undefined) {
                console.log('outputting', sitesUsed)
                sitesUsed.push(data.trending[randomIndex].item.siteName)

                let itemClone = resultItemClone.clone()
                itemClone.find('[fdn-teaser-image]')
                  .attr('src', data.trending[randomIndex].item.imageUrl)
                itemClone.find('[fdn-site-name]')
                  .text(data.trending[randomIndex].item.siteName)
                itemClone.find('[fdn-teaser-headline]')
                  .html(data.trending[randomIndex].item.teaserHeadline)
                itemClone.find('[fdn-teaser-infoline]')
                  .html(data.trending[randomIndex].item.teaserInfoline)
                itemClone.find('[fdn-teaser-url]')
                  .attr('href', data.trending[randomIndex].item.teaserUrl)

                itemClone.appendTo(resultItemsContainerClone)
              }
            }
          }

          if(resultItemsContainerClone) {
            jQuery(resultsContainerSelector)
              .find('div')
              .first()
              .replaceWith(resultItemsContainerClone)
          }else{
            jQuery(componenSelector)
              .replaceWith('<!-- ' + componenSelector + ' No Trending Results -->')
          }
        }

        jQuery.ajax({
          url: ajaxUrl,
          cache: false,
          type: 'GET',
          data: params,
          dataType: 'json',
          success: requestSuccess,
          error: requestError
        })
      })()
      </script>
</div>
</div>
<div id="gridSpanningFeature2">
</div>
<div id="gridColumnContainer" class="clearfix">
<div id="gridMainColumn1">
</div>
<div id="gridMainColumn2">
</div>
</div>
</div>
<div id="gridRightColumn">
<div id="gridSpanningIsland">
<div id="TabbedPopularity" class="SpanningIsland ContentDefault ">
<h2>Most Popular</h2>
<div class="tabs">
<div id="tabViewed" class="tabCurrent tab"><a href="#">Most Read</a></div>
<div id="tabCommented" class="tabBack tab"><a href="#">Most Commented</a></div>
<div id="tabLatest" class="tabBack tab tabLast"><a href="#">This Issue</a></div>
</div>
<div class="popularityBody">
<ol class="moduleList">
<li>
<h4 class="headline"><a href="https://www.riverfronttimes.com/stlouis/the-lot-concert-series-to-take-over-the-big-top-in-grand-center/Content?oid=37133491&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">The Lot Concert Series to Take Over the Big Top in Grand Center <span class="more">Read More</span></a></h4>
</li>
</ol>
</div>
<div class="popularityBody" style="display:none">
<div id="recentcomments" class="dsq-widget"><script type="text/javascript" src="https://disqus.com/forums/riverfronttimes2/popular_threads_widget.js?num_items=5&hide_avatars=1&avatar_size=32&excerpt_length=200"></script></div>
</div>
<div class="popularityBody" style="display:none">
<div class="currentIssue">
<a href="https://www.riverfronttimes.com/stlouis/IssueArchives?issue=37184555&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity" class="no-foundation-imgeditor">
<img src="/imager/b/cover/37184555/557d/Cover_1_.jpg" alt="Issue Cover" />
</a>
<p>February 16-22, 2022</p>
</div>
<ol class="moduleList">
<li>
<h4 class="headline"><a href="https://www.riverfronttimes.com/stlouis/hartmann-its-time-for-st-louis-to-quit-whining-about-stan-kroenke/Content?oid=37211530&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity"><p>Hartmann: It's Time For St. Louis To Quit Whining About Stan Kroenke <span class="more">Read More</span></a></h4>
</li>
<li>
<h4 class="headline"><a href="https://www.riverfronttimes.com/stlouis/st-louis-standards-kenricks-is-not-just-a-butcher-shop-its-an-institution/Content?oid=37185716&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">St. Louis Standards: Kenrick's Is Not Just a Butcher Shop. It's an Institution <span class="more">Read More</span></a></h4>
</li>
<li>
<h4 class="headline"><a href="https://www.riverfronttimes.com/stlouis/jess-dugan-explores-identity-intimacy-and-connection-in-new-book/Content?oid=37185720&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Jess Dugan Explores Identity, Intimacy and Connection in New Book <span class="more">Read More</span></a></h4>
</li>
<li>
<h4 class="headline"><a href="https://www.riverfronttimes.com/stlouis/grand-pied-dazzles-with-perfectly-executed-home-cooking-staples/Content?oid=37185708&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Grand Pied Dazzles with Perfectly Executed Home Cooking Staples <span class="more">Read More</span></a></h4>
</li>
<li>
<h4 class="headline"><a href="https://www.riverfronttimes.com/stlouis/the-internet-accused-her-of-murder-now-elizabeth-cooke-tells-her-story/Content?oid=37184560&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">The Internet Accused Her Of Murder. Now, Elizabeth Cooke Tells Her Story <span class="more">Read More</span></a></h4>
</li>
</ol>
</div>
</div>
<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function () {
    dnSetupTabGroup(
        $$("#TabbedPopularity div.tabs>div"),
        $$("#TabbedPopularity div.popularityBody"),
        "tabCurrent", "tabBack"
    );
    
    // Deactivate links.
    $$("#TabbedPopularity div.tabs>div a").each(function (a) {
        a.onclick = function () { 
          setTimeout(function(){ jQuery('#TabbedPopularity li').css('counter-reset','item'); },10);
          return false; 
        };
    });
});
//-->
</script>

<div id="SearchRightCol" class="SpanningIsland ContentDefault  search-wrap">
<form class="prepTextForm" id="searchbox_007740603287178168358:htmjd4xll5w" action="https://posting.riverfronttimes.com/stlouis/Search">
<input type="hidden" name="cx" value="007740603287178168358:htmjd4xll5w" />
<input type="hidden" name="cof" value="FORID:9" />
<input id="search-submit" type="submit" name="sa" value="Search" />
<input id="search-input" autocomplete="off" type="text" name="q" size="25" placeholder="Search" />
</form>
<ul id="search-dropdown" class="search-dropdown" style="display:none;">
<li class="search-option"><a class="search-all" href="https://posting.riverfronttimes.com/stlouis/Search?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SearchRightCol"><span class="dark-search-icon"></span>&nbsp;All</a></li>
<li class="search-option"><a href="https://www.riverfronttimes.com/stlouis/ArticleArchives?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SearchRightCol"><span class="dark-search-icon"></span>&nbsp;in Articles &amp; Posts</a></li>
<li class="search-option"><a href="https://www.riverfronttimes.com/stlouis/EventSearch?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SearchRightCol"><span class="dark-search-icon"></span>&nbsp;in Events</a></li>
<li class="search-option"><a href="https://www.riverfronttimes.com/stlouis/LocationSearch?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SearchRightCol"><span class="dark-search-icon"></span>&nbsp;in Locations</a></li>
</ul>
</div>
<script type="text/javascript">
/* SEARCH WIDGET */

var searchInputSelector = '#search-input';
var searchFormSelector = 'form.prepTextForm';

dropDownLinksEmptyKeywordAlert = function (){
  jQuery(searchInputSelector).attr('placeholder','Please enter a keyword.');
  setTimeout(function(){jQuery(searchInputSelector).attr('placeholder','Search');},3000);
}

// 
jQuery(searchFormSelector+' input[type="submit"]').click(function(e){
  jQuery(searchInputSelector).click();
  if(jQuery(searchInputSelector).val() == ""){
    e.preventDefault();
    dropDownLinksEmptyKeywordAlert();
  }
});

dropDownLinks = new FloatingPanel(
  'search-input', // 
  'search-dropdown', // 
  {
    effects: 'off',
    closeDelay: 1,
    triggerEvent: 'click',
    allowDefault: true,
    beforeOpen: function() {
      var searchInput = jQuery(searchInputSelector);
      jQuery('.search-option a').click(function(e){
        e.preventDefault(); // 
        // 
        if(jQuery(searchInputSelector).val() != ""){
          if(jQuery(e.target).hasClass('search-all')){
            jQuery(searchFormSelector).submit();
          } else {
            var newLocation = jQuery(e.target).attr('href') || "";
            if( newLocation.match(/\?/)){
              newLocation = newLocation+'&';
            }else{
              newLocation = newLocation+'?';
            }
            window.location = newLocation + "keywords=" + jQuery(searchInputSelector).val() +  "&submit=Search";
          }
        }else{
          dropDownLinksEmptyKeywordAlert();
        }
      });

      //
      SearchRightColCloseSearchPanel = function(event){
        if(jQuery(event.target).parents('#SearchRightCol').length == 0){
          dropDownLinks.closePanel();
        }
      }
      jQuery(document).click(function(e){SearchRightColCloseSearchPanel(e);});
    },
    beforeClose: function() {
      //
      jQuery(document).off('click', '*', SearchRightColCloseSearchPanel);
    },
    togglePanel: function(){
      //
    }
  }
);
</script>

<div id="AdMediumRectangle1300x250" class="SpanningIsland ContentDefault ">

<div id="div-gpt-ad-stl_300x250-1" style="" data-content-type="ad" data-slot="/43707298/STL_300x250" data-output="asynchronous" data-width="300" data-height="250">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-stl_300x250-1');
                });
              </script>
</div>
</div>
<div id="CurrentIssuu" class="SpanningIsland ContentDefault ">
<h2>Read the Digital Print Issue</h2>
<div class="wrap">
<h3>February 16, 2022</h3>
<iframe src="https://e.issuu.com/embed.html?d=rft_021622&hideIssuuLogo=true&pageLayout=singlePage&u=euclidmediagroup" allowfullscreen allow="fullscreen" style="border:none;width:100%;height:300px;"></iframe>
<p style="margin:10px 0;">
<a class="more" href="https://www.riverfronttimes.com/stlouis/IssueArchives">View more issues</a>
</p>
</div>
</div>
<div id="AdMediumRectangle2300x250" class="SpanningIsland ContentDefault ">

<div id="div-gpt-ad-stl_300x250-2" style="" data-content-type="ad" data-slot="/43707298/STL_300x250" data-output="asynchronous" data-width="300" data-height="250">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-stl_300x250-2');
                });
              </script>
</div>
</div>
<div id="NewsletterSignup" class="SpanningIsland ContentDefault ">
<h2>Newsletters</h2>
<div class="wrap">

<h3>Never miss a beat</h3>
<a href="/stlouis/Newsletters/Page" style="float:right;border: 0; color: rgb(255, 255, 255); display: inline-block; padding: 8px 15px; text-shadow: none; border-top-left-radius: 8px; border-top-right-radius: 8px; border-bottom-right-radius: 8px; border-bottom-left-radius: 8px; background-color: rgb(217, 31, 52);font-family:'Montserrat',sans-serif;text-transform: uppercase;text-decoration:none;">Sign Up Now</a>
<p>Subscribe now to get the latest news delivered right to your inbox.</p>

</div>
</div>
<div id="SpecialIssues" class="SpanningIsland ContentDefault ">
<h2><a href="https://www.riverfronttimes.com/stlouis/st-louis-guides/Section?oid=2348807&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues">Special Issues</a></h2>
<div class="reportBox">
<a href="/stlouis/summer-guide/Category?oid=2349249&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" style="background-image:url(https://media2.riverfronttimes.com/riverfronttimes/imager/u/original/2773484/summerguide.jpg);">
<span class="grayRedBox">Summer Guide</span>
</a>
</div>
<div class="reportBox">
<a href="/musicblog/archives/music-issue/?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" style="background-image:url(https://media2.riverfronttimes.com/riverfronttimes/imager/u/original/2773487/musicissue.jpg);">
<span class="grayRedBox">Music Issue</span>
</a>
</div>
<a href="https://www.riverfronttimes.com/stlouis/st-louis-guides/Section?oid=2348807&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues">More...</a>
</div>
<div id="AdMediumRectangle3300x250" class="SpanningIsland ContentDefault ">

<div id="div-gpt-ad-stl_300x250-3" style="" data-content-type="ad" data-slot="/43707298/STL_300x250" data-output="asynchronous" data-width="300" data-height="250">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-stl_300x250-3');
                });
              </script>
</div>
</div>
<div id="PhotoSlideshows" class="SpanningIsland ContentDefault ">
<h2><a href="http://photos.riverfronttimes.com" target="_blank">Newest Slideshows</a></h2>
<iframe src="https://www.riverfronttimes.com/stlouis/snoop-dogg-is-playing-the-family-arena-and-yes-youre-old/Content?ajaxComponent=PhotoSlideshows&iframeRendered=yes" height="419" width="364" scrolling="no" frameborder="0"></iframe>
</div>

<div id="TabbedCalendar" class="SpanningIsland ContentDefault ">
<h2>Best Things to Do In St. Louis</h2>
<div class="tabs">
<div id="tabEvents" class="tab"><a href="#">Events</a></div>
<div id="tabMusic" class="tab"><a href="#">Music</a></div>
<div id="tabMovies" class="tab"><a href="#">Movies</a></div>
<div id="tabArts" class="tab"><a href="#">Arts</a></div>
<div id="tabDining" class="tab tabLast"><a href="#">Dining</a></div>
</div>
<div class="eventTabGuts" style="display:none">
<div class="tabsButtonRow">
<a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?narrowByDate=Today&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
<a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?narrowByDate=Tomorrow&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
<a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?narrowByDate=This%20Weekend&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
</div>
<ol class="moduleList">
<li>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/panel-discussion-nike-and-harris-stowe-sji-presents-progress-post-ferguson/Event?oid=37195935&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Panel Discussion: Nike and Harris-Stowe SJI presents: Progress Post Ferguson <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/bestselling-author-of-the-expanse-series-daniel-abraham-discusses-new-book-with-co-author-ty-franck-and-left-bank-books/Event?oid=37084764&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Bestselling Author of the Expanse series Daniel Abraham Discusses New Book with Co-author Ty Franck & Left Bank Books <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/saint-louis-billiken-mens-basketball-vs-st-josephs-hawks-mens-basketball/Event?oid=37187630&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Saint Louis Billiken Mens Basketball vs. St. Joseph's Hawks Mens Basketball <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/bonsack-gallery-presents-andrew-newman-plastic-ocean/Event?oid=37024994&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Bonsack Gallery Presents Andrew Newman: Plastic Ocean <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/kalven-duncan-rachel-ferguson-and-judy-duggan-mccormack/Event?oid=36613626&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Kalven Duncan, Rachel Ferguson, & Judy Duggan-McCormack <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
</ol>
</div>
<div class="eventTabGuts" style="display:none">
<div class="tabsButtonRow">
<a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?eventSection=2759668&amp;narrowByDate=Today&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
<a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?eventSection=2759668&amp;narrowByDate=Tomorrow&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
<a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?eventSection=2759668&amp;narrowByDate=This%20Weekend&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
</div>
<ol class="moduleList">
<li>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/eric-mcspadden-and-margaret-bienchetta/Event?oid=37178558&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Eric McSpadden and Margaret Bienchetta <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/idkhow-presents-the-thought-reform-tour/Event?oid=36448360&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
iDKHOW presents The Thought Reform Tour <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/notes-from-home-kevin-buckley/Event?oid=37179453&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Notes from Home: Kevin Buckley <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/i-dont-know-how-but-they-found-me/Event?oid=37178544&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
I Don't Know How But They Found Me <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/talisk/Event?oid=36616663&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Talisk <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
</ol>
</div>
<div class="eventTabGuts" style="display:none">
<div class="tabsButtonRow">
<a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?eventSection=2762983&amp;narrowByDate=Today&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
<a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?eventSection=2762983&amp;narrowByDate=Tomorrow&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
<a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?eventSection=2762983&amp;narrowByDate=This%20Weekend&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
</div>
<ol class="moduleList">
<li style="list-style-type:none;">No results <a class="more" href="https://www.riverfronttimes.com/stlouis/EventSearch?eventSection=2762983&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar"> Film Event Search</a></li>
</ol>
</div>
<div class="eventTabGuts" style="display:none">
<div class="tabsButtonRow">
<a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?eventSection=2762986&amp;narrowByDate=Today&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
<a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?eventSection=2762986&amp;narrowByDate=Tomorrow&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
<a class="grayRedBox" href="https://www.riverfronttimes.com/stlouis/EventSearch?eventSection=2762986&amp;narrowByDate=This%20Weekend&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
</div>
<ol class="moduleList">
<li>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/bonsack-gallery-presents-andrew-newman-plastic-ocean/Event?oid=37024994&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Bonsack Gallery Presents Andrew Newman: Plastic Ocean <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/kalven-duncan-rachel-ferguson-and-judy-duggan-mccormack/Event?oid=36613626&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Kalven Duncan, Rachel Ferguson, & Judy Duggan-McCormack <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/curator-tour-lisa-melandri-wassan-al-khudhairi-and-misa-jeffereis/Event?oid=37150961&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Curator Tour: Lisa Melandri, Wassan Al-Khudhairi, and Misa Jeffereis <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/the-places-well-go-art-exhibit/Event?oid=36691356&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
The Places We'll Go Art Exhibit <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/learn-to-play-comedysportz-workshops-the-winter-opera/Event?oid=37187606&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Learn to Play ComedySportz - Workshops @ The Winter Opera <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
</ol>
</div>
<div class="eventTabGuts" style="display:none">
<ol class="moduleList">
<li>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/lombardos-restaurant/Location?oid=2683933&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Lombardo's Restaurant <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/sushi-bistro/Location?oid=2695521&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Sushi Bistro <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.riverfronttimes.com/stlouis/b-halls-bar-and-grill/Location?oid=2684227&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
B. Hall's Bar & Grill <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
</ol>
<form name="diningSearchForm" method="get" action="https://www.riverfronttimes.com/stlouis/LocationSearch">
<input type="hidden" name="locationSection" value="2683245" />
<input type="hidden" name="guide" value="2124367" />
<select name="locationCategory">
<option value="">-All Categories-</option>
<option value="2683451">Afghan</option>
<option value="2683449">African</option>
<option value="2683395">American</option>
<option value="2683320">Appetizers</option>
<option value="2683393">Armenian</option>
<option value="2683466">Asian</option>
<option value="2683480">Asian Fusion</option>
<option value="2683434">Austrian</option>
<option value="2683468">Bakery</option>
<option value="2683360">Bar Food</option>
<option value="2683465">Barbecue</option>
<option value="2683505">Beignet</option>
<option value="2683431">Belgian</option>
<option value="2683404">Bistro</option>
<option value="2683313">Bosnian</option>
<option value="2683378">Brazilian</option>
<option value="2683334">Breakfast</option>
<option value="2683366">Brewery</option>
<option value="2683495">British</option>
<option value="2683368">Brunch</option>
<option value="2683460">Buffet</option>
<option value="2683351">Burgers</option>
<option value="2683371">Butcher Shop</option>
<option value="2683379">Cafe</option>
<option value="2683407">Cajun</option>
<option value="2683286">California</option>
<option value="2683467">Caribbean</option>
<option value="2683391">Central American</option>
<option value="2683447">Chinese</option>
<option value="2683314">Coffeehouse</option>
<option value="2683398">Comfort Foods</option>
<option value="2683408">Contemporary</option>
<option value="2683444">Continental</option>
<option value="2683484">Creole</option>
<option value="2683430">Crepes</option>
<option value="2683285">Cuban</option>
<option value="2683325">Deli</option>
<option value="2683390">Dessert</option>
<option value="2683332">Diner</option>
<option value="2683383">Eclectic</option>
<option value="2683311">English</option>
<option value="2683301">Eritrean</option>
<option value="2683481">Ethiopian</option>
<option value="2683341">European</option>
<option value="2683475">Fast Casual</option>
<option value="2683433">Fast Food</option>
<option value="2683300">Filipino</option>
<option value="2683485">Fine Dining</option>
<option value="2683411">Fondue</option>
<option value="2683270">Food Trucks</option>
<option value="2683376">French</option>
<option value="2683482">Fried Chicken</option>
<option value="2683338">Frozen Yogurt</option>
<option value="2683420">Fusion</option>
<option value="2683339">Gastro Pub</option>
<option value="2683388">Gelato</option>
<option value="2683424">German</option>
<option value="2683331">Gluten-Free</option>
<option value="2683349">Gourmet</option>
<option value="2683348">Greek</option>
<option value="2683330">Grill</option>
<option value="2683370">Grocery</option>
<option value="2683471">Gyros</option>
<option value="2683497">Halal</option>
<option value="2683477">Health</option>
<option value="2683342">Hot Dogs</option>
<option value="2683377">Ice Cream</option>
<option value="2683305">Indian</option>
<option value="2683381">Indonesian</option>
<option value="2683309">International</option>
<option value="2683427">Irish</option>
<option value="2683374">Italian</option>
<option value="2683296">Jamaican</option>
<option value="2683323">Japanese</option>
<option value="2683345">Jewish</option>
<option value="2683372">Korean</option>
<option value="2683413">Kosher</option>
<option value="2683316">Latin</option>
<option value="2683401">Latin American</option>
<option value="2683299">Lebanese</option>
<option value="2683501">Market</option>
<option value="2683284">Mediterranean</option>
<option value="2683500">Mexican</option>
<option value="2683450">Middle Eastern</option>
<option value="2683428">Modern American</option>
<option value="2683396">Modern European</option>
<option value="2683367">Mongolian</option>
<option value="2683498">Moroccan</option>
<option value="2683426">Nepalese</option>
<option value="2683290">New American</option>
<option value="2683362">Organic</option>
<option value="2683298">Pakistani</option>
<option value="2683442">Paleo</option>
<option value="2683355">Pan-Asian</option>
<option value="2683483">Paninis</option>
<option value="2683397">Pasta</option>
<option value="2683302">Pastries</option>
<option value="2683382">Persian</option>
<option value="2683402">Peruvian</option>
<option value="2683502">Pizza</option>
<option value="2683496">Polynesian</option>
<option value="2683329">Raw Food</option>
<option value="2683414">Recommended</option>
<option value="2683249">Restaurants</option>
<option value="2683303">Russian</option>
<option value="2683438">Salads</option>
<option value="2683356">Sandwiches</option>
<option value="2683479">Scottish</option>
<option value="2683308">Seafood</option>
<option value="2683489">Sicilian</option>
<option value="2683389">Small Plates</option>
<option value="2683476">Smoothies</option>
<option value="2683343">Soul Food</option>
<option value="2683440">Soups</option>
<option value="2683416">South American</option>
<option value="2683457">Southern</option>
<option value="2683493">Southwestern</option>
<option value="2683456">Spanish</option>
<option value="2683478">Specialties</option>
<option value="2683490">Steakhouse</option>
<option value="2683453">Street Food</option>
<option value="2683459">Sushi</option>
<option value="2683363">Syrian</option>
<option value="2683488">Tapas</option>
<option value="2683353">Tea</option>
<option value="2683446">Tex-Mex</option>
<option value="2683310">Thai</option>
<option value="2683437">Traditional</option>
<option value="2683295">Turkish</option>
<option value="2683292">Tuscan</option>
<option value="2683335">Vegan</option>
<option value="2683297">Vegetarian</option>
<option value="2683354">Vietnamese</option>
<option value="2683470">Welsh</option>
<option value="2683328">Wine Bar</option>
<option value="2683318">Wings</option>
<option value="2683369">Wraps</option>
</select>
<select name="neighborhood">
<option value="">-All Neighborhoods-</option>
<option value="2682456">ST. LOUIS - DOWNTOWN/ MIDTOWN</option>
<option value="2682516">&nbsp;&nbsp;St. Louis - Central West End</option>
<option value="2682518">&nbsp;&nbsp;St. Louis - Downtown</option>
<option value="2682519">&nbsp;&nbsp;St. Louis - Forest Park</option>
<option value="2682521">&nbsp;&nbsp;St. Louis - Grand Center</option>
<option value="2682522">&nbsp;&nbsp;St. Louis - Lafayette Square</option>
<option value="2682523">&nbsp;&nbsp;St. Louis - Midtown</option>
<option value="2682502">&nbsp;&nbsp;St. Louis - North Downtown</option>
<option value="2682524">&nbsp;&nbsp;St. Louis - Riverfront</option>
<option value="2682525">&nbsp;&nbsp;St. Louis - Skinker/DeBaliviere</option>
<option value="2682530">&nbsp;&nbsp;St. Louis - Washington Avenue</option>
<option value="2682457">ST. LOUIS - NORTH CITY</option>
<option value="2682499">&nbsp;&nbsp;St. Louis - Bellefontaine</option>
<option value="2682500">&nbsp;&nbsp;St. Louis - Fairground Park</option>
<option value="2682501">&nbsp;&nbsp;St. Louis - North City</option>
<option value="2682458">ST. LOUIS - SOUTH CITY</option>
<option value="2682517">&nbsp;&nbsp;St. Louis - Dogtown</option>
<option value="2682520">&nbsp;&nbsp;St. Louis - Forest Park Southeast</option>
<option value="2682538">&nbsp;&nbsp;St. Louis - Soulard</option>
<option value="2682503">&nbsp;&nbsp;St. Louis - South City</option>
<option value="2682527">&nbsp;&nbsp;St. Louis - South Grand</option>
<option value="2682504">&nbsp;&nbsp;St. Louis - St. Louis Hills</option>
<option value="2682535">&nbsp;&nbsp;St. Louis - The Grove</option>
<option value="2682528">&nbsp;&nbsp;St. Louis - The Hill</option>
<option value="2682529">&nbsp;&nbsp;St. Louis - Tower Grove</option>
<option value="2682450">METRO EAST</option>
<option value="2682464">&nbsp;&nbsp;Belleville/ Fairview Heights</option>
<option value="2682468">&nbsp;&nbsp;Collinsville/ Edwardsville</option>
<option value="2682472">&nbsp;&nbsp;Dupo/ Columbia</option>
<option value="2682473">&nbsp;&nbsp;East St. Louis/ Cahokia</option>
<option value="2682478">&nbsp;&nbsp;Grafton/ Godfrey/ Alton</option>
<option value="2682479">&nbsp;&nbsp;Granite City</option>
<option value="2682507">&nbsp;&nbsp;Venice/ Madison/ Brooklyn</option>
<option value="2682451">NORTH ST. LOUIS COUNTY</option>
<option value="2682463">&nbsp;&nbsp;Airport</option>
<option value="2682475">&nbsp;&nbsp;Ferguson</option>
<option value="2682476">&nbsp;&nbsp;Florissant</option>
<option value="2682483">&nbsp;&nbsp;Jennings</option>
<option value="2682490">&nbsp;&nbsp;North St. Louis County</option>
<option value="2682496">&nbsp;&nbsp;St. Ann</option>
<option value="2682454">SOUTH ST. LOUIS COUNTY</option>
<option value="2682462">&nbsp;&nbsp;Affton/ Concord</option>
<option value="2682470">&nbsp;&nbsp;Crestwood/ Sunset Hills/ Sappington/ South Lindbergh</option>
<option value="2682474">&nbsp;&nbsp;Fenton</option>
<option value="2682489">&nbsp;&nbsp;Mehlville/ Oakville/ Lemay</option>
<option value="2682445">CENTRAL ST. LOUIS COUNTY</option>
<option value="2682465">&nbsp;&nbsp;Brentwood</option>
<option value="2682487">&nbsp;&nbsp;Maplewood</option>
<option value="2682495">&nbsp;&nbsp;Richmond Heights</option>
<option value="2682459">WEST ST. LOUIS COUNTY</option>
<option value="2682466">&nbsp;&nbsp;Chesterfield</option>
<option value="2682471">&nbsp;&nbsp;Creve Coeur</option>
<option value="2682512">&nbsp;&nbsp;Des Peres</option>
<option value="2682513">&nbsp;&nbsp;Eureka</option>
<option value="2682514">&nbsp;&nbsp;Frontenac</option>
<option value="2682480">&nbsp;&nbsp;Hazelwood/ Bridgeton/ Earth City</option>
<option value="2682486">&nbsp;&nbsp;Manchester/ Ballwin</option>
<option value="2682488">&nbsp;&nbsp;Maryland Heights</option>
<option value="2682531">&nbsp;&nbsp;Town & Country</option>
<option value="2682506">&nbsp;&nbsp;Valley Park</option>
<option value="2682510">&nbsp;&nbsp;Wildwood</option>
<option value="2682446">CLAYTON/ U. CITY/ LADUE</option>
<option value="2682467">&nbsp;&nbsp;Clayton</option>
<option value="2682511">&nbsp;&nbsp;Delmar/ The Loop</option>
<option value="2682485">&nbsp;&nbsp;Ladue</option>
<option value="2682515">&nbsp;&nbsp;Olive Boulevard</option>
<option value="2682494">&nbsp;&nbsp;Olivette/ Overland</option>
<option value="2682532">&nbsp;&nbsp;University City</option>
<option value="2682449">KIRKWOOD/ WEBSTER GROVES</option>
<option value="2682484">&nbsp;&nbsp;Kirkwood</option>
<option value="2682508">&nbsp;&nbsp;Webster Groves</option>
<option value="2682455">ST. CHARLES COUNTY</option>
<option value="2682491">&nbsp;&nbsp;O'Fallon, MO</option>
<option value="2682497">&nbsp;&nbsp;St. Charles</option>
<option value="2682498">&nbsp;&nbsp;St. Charles County</option>
<option value="2682505">&nbsp;&nbsp;St. Peters</option>
<option value="2682509">&nbsp;&nbsp;Wentzville</option>
<option value="3081641">HERMANN</option>
<option value="3081642">&nbsp;&nbsp;Hermann</option>
<option value="2682448">JEFFERSON COUNTY</option>
<option value="2682482">&nbsp;&nbsp;Jefferson County</option>
<option value="2682453">OUTSTATE MO</option>
<option value="2682469">&nbsp;&nbsp;Columbia</option>
<option value="2682481">&nbsp;&nbsp;Jefferson City</option>
<option value="2682533">&nbsp;&nbsp;Lexington</option>
<option value="2682493">&nbsp;&nbsp;Outstate MO</option>
<option value="2682447">FRANKLIN COUNTY</option>
<option value="2682477">&nbsp;&nbsp;Franklin County</option>
<option value="2682452">OUTSTATE IL</option>
<option value="2682534">&nbsp;&nbsp;Murphysboro</option>
<option value="2682492">&nbsp;&nbsp;Outstate IL</option>
<option value="2682537">&nbsp;&nbsp;St. Libory</option>
<option value="33361219">ONLINE</option>
<option value="33361220">&nbsp;&nbsp;Online Only</option>
<option value="2682460">OUT OF TOWN</option>
<option value="2682536">&nbsp;&nbsp;Out of Town</option>
<option value="2682461">BEYOND</option>
<option value="2682539">&nbsp;&nbsp;Unknown</option>
</select>
<div class="searchBox">
<input type="text" name="keywords" title="Enter keyword" placeholder="Search" autocomplete="off" class="text" value="" />
<input type="submit" value="go" />
</div>
</form>
</div>
</div>
<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function () {
    dnSetupTabGroup(
        $$("#TabbedCalendar div.tabs>div"),
        $$("#TabbedCalendar div.eventTabGuts"),
        "tabCurrent", "tabBack", 1
    );

    // Deactivate links.
    $$("#TabbedCalendar div.tabs>div a").each(function (a) {
        a.onclick = function () { 
          setTimeout(function(){ jQuery('#TabbedCalendar li').css('counter-reset','item'); },10);
          return false; 
        };
    });
});
//-->
</script>
</div>
<div id="gridMainSidebar">
</div>
<div id="gridAdSidebar">
</div>
<div id="gridBottomSidebar">
</div>
</div>

<div id="gridFooter">
<div id="FooterInfo" class="GlobalFooter ContentDefault ">
<div class="footerCustomInfo">
<h2>Riverfront Times</h2>
<p>PO Box 179456</p>
<p>St. Louis, MO 63117</p>
<p>Main: (314) 754-5966</p>
<p>Advertising: (314) 754-5914</p>
<p>Classified: (314) 754-5925</p>
</div>
<div class="footerCustomWrap">
<div class="footerCustomNav">
<ul>
<li><a target="_top" href="/stlouis/ContactUs/Page">Contact RFT</a></li>
<li><a target="_top" href="https://www.riverfronttimes.com/stlouis/AdvertiseWithRiverfrontTimes/Page">Advertise</a></li>
<li><a target="_blank" href="http://www.vmgadvertising.com/">National Advertising</a></li>
<li><a target="_top" href="/stlouis/Jobs/Page">Work Here</a></li>
</ul>
<p>All parts of this site Copyright &copy; 2022 Riverfront Times.</p>
</div>
<div class="footerCustomLogin">
<ul data-view="loggedin" style="display:none">
<li><strong data-label="username">Username</strong> / </li>
<li><a href="https://posting.riverfronttimes.com/stlouis/MyProfile">View Profile</a> / </li>
<li><a href="https://posting.riverfronttimes.com/stlouis/Profile/MySettings">Edit Profile</a> / </li>
<li><a href="https://www.riverfronttimes.com/stlouis/Logout">Log Out</a></li>
</ul>
<ul data-view="loggedout" style="display:none">
<li><a href="#LogIn">Log in</a> / </li>
<li><a href="#CreateAccount">Create Account</a></li>
</ul>
</div>
<script>
        new Foundation.LoginRequiredComponent("FooterInfo");
      </script>
</div>
<div class="clear"></div>
</div>

<div id="AdFooter728x90" class="GlobalFooter ContentDefault ">

<div id="div-gpt-ad-stl_728x90-2" style="" data-content-type="ad" data-slot="/43707298/STL_728x90" data-output="asynchronous" data-width="728" data-height="90">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-stl_728x90-2');
                });
              </script>
</div>
</div>
<div id="FooterNavigation" class="GlobalFooter ContentDefault ">
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>
<a href="/stlouis/news/Section?oid=2348800" target="_">
News
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="https://www.riverfronttimes.com/stlouis/st-louis-metro-news/Category?oid=2349235" target="_self">St. Louis Metro News</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/missouri-news/Category?oid=37051540" target="_self">Missouri News</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/hartmann/Category?oid=2349242" target="_self">Hartmann</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/IssueArchives?issue=thisweek" target="_blank">Digital Issue</a></li>
<li><a href="https://photos.riverfronttimes.com/category/newsslideshows/?slide=1" target="_self">News Slideshows</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>
<a href="/stlouis/arts-and-culture/Section?oid=2348805" target="_">
Arts & Culture
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="https://www.riverfronttimes.com/stlouis/arts-stories-and-interviews/Category?oid=2512891" target="_self">Arts Stories & Interviews</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/theater-and-performance/Topics?oid=37051582" target="_self">Theater & Performance</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/visual-art/Topics?oid=37051583" target="_self">Visual Art</a></li>
<li><a href="https://photos.riverfronttimes.com/category/artsslideshows/" target="_self">Arts & Culture Slideshows</a></li>
</ul>
</div>
</div>
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>
<a href="/stlouis/food-drink/Section?oid=2348803" target="_">
Food & Drink
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="https://www.riverfronttimes.com/stlouis/food-and-drink-news/Category?oid=2512889" target="_self">Food & Drink News</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/restaurants/Category?oid=2349238" target="_self">Restaurant Reviews</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/st-louis-standards/Category?oid=37051480" target="_self">St. Louis Standards</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/LocationSearch?locationSection=2683245/stlouis/LocationSearch?locationSection=2683245&guide=2124367" target="_self">Find a Restaurant</a></li>
<li><a href="https://photos.riverfronttimes.com/category/foodslideshows" target="_self">Food & Drink Slideshows</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>
<a href="/stlouis/music/Section?oid=2348804" target="_">
Music
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="https://www.riverfronttimes.com/stlouis/music/Section?oid=2348804" target="_self">Music News & Interviews</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/EventSearch?eventCategory=2960217&sortType=date&v=d" target="_self">Find a Concert</a></li>
<li><a href="https://photos.riverfronttimes.com/category/musicslideshows/" target="_self">Music Slideshows</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/FreeStuff" target="_self">Giveaways</a></li>
</ul>
</div>
</div>
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>
<a href="/stlouis/movies/Section?oid=2348802" target="_">
Movies
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="https://www.riverfronttimes.com/stlouis/movie-reviews-and-news/Category?oid=2349243" target="_self">Movie Reviews & News</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/MovieTimes" target="_self">Movie Times</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/LocationSearch?locationCategory=2683256&sortType=name" target="_self">Find a Theater</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>
<a href="/stlouis/reeferfront-times/Section?oid=35262379" target="_">
Reeferfront Times
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="https://www.riverfronttimes.com/blogs/WeedNews/" target="_self">Weed News</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/dispensary-reviews/Category?oid=35262629" target="_self">Dispensary Reviews</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/LocationSearch?locationSection=35262377&sortType=name" target="_self">Dispensary Directory</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>
<a href="/stlouis/EventSearch" target="_">
Calendar
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="https://www.riverfronttimes.com/stlouis/EventSearch?narrowByDate=Today" target="_self">Today's Events</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/EventSearch?narrowByDate=This%20Weekend" target="_self">This Weekend</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/EventSearch?eventCategory=2759675&sortType=date&v=d" target="_self">Free Events</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/Events/AddEvent" target="_self">Submit an Event</a></li>
</ul>
</div>
</div>
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>
<a href="/stlouis/BestOf" target="_">
Best Of
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="https://www.riverfronttimes.com/stlouis/arts-and-entertainment/BestOf?category=2349229" target="_self">Arts & Entertainment</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/food-and-drink/BestOf?category=2349230" target="_self">Food & Drink</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/people-and-places/BestOf?category=2349227" target="_self">People & Places</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/sports-and-recreation/BestOf?category=2349228" target="_self">Sports & Recreation</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/goods-and-services/BestOf?category=2349244" target="_self">Goods & Services</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>St. Louis Guides</h3>
<ul class="sublinkGroup">
<li><a href="https://www.riverfronttimes.com/stlouis/summer-guide/Category?oid=2349249" target="_self">Summer Guide</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/city-guide/Category?oid=3138571" target="_self">City Guide</a></li>
<li><a href="https://www.riverfronttimes.com/musicblog/archives/music-issue/" target="_self">Music Issue</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/BestOf" target="_self">Best Of St. Louis</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/sponsored/Section?oid=33881280" target="_self">Sponsored Articles</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>
<a href="/stlouis/FreeStuff" target="_">
Promotions & Giveaways
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="https://www.riverfronttimes.com/stlouis/FreeStuff?category=3014930" target="_self">RFT Events</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/FreeStuff?category=2199663" target="_self">Giveaways</a></li>
</ul>
</div>
</div>
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>
<a href="/stlouis/SupportLocalJournalism/Page" target="_">
Support
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="https://www.riverfronttimes.com/stlouis/SupportLocalJournalism/Page" target="_self">Donate</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/Newsletters/Page" target="_self">Subscribe</a></li>
<li><a href="https://shop.euclidmediagroup.com/collections/riverfront-times" target="_blank">Shop RFT</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/AdvertiseWithRiverfrontTimes/Page" target="_self">Advertise</a></li>
<li><a href="https://www.facebook.com/riverfronttimes" target="_blank">Facebook</a></li>
<li><a href="https://twitter.com/riverfronttimes/" target="_blank">Twitter</a></li>
<li><a href="https://instagram.com/riverfronttimes" target="_blank">Instagram</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>
<a href="/stlouis/AboutRiverfrontTimes/Page" target="_">
About Us
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="https://www.riverfronttimes.com/stlouis/ContactUs/Page" target="_self">Contact Us</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/AdvertiseWithRiverfrontTimes/Page" target="_self">Advertise</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/Jobs/Page" target="_self">Jobs</a></li>
<li><a href="https://www.riverfronttimes.com/stlouis/Policies/Page" target="_self">Policies</a></li>
</ul>
</div>
</div>
</div>

<style>
.sister-links {
  padding: 1em 0;
  border-top: 1px solid #ccc;
}
.sister-links h3 {
  text-align: center;
  font-size: 16px;
}
.sister-links h4 {
  text-align: center;
  font-size: 12px;
  text-transform:uppercase
}
.sister-links p {
  text-align: center;
  font-size: 12px;
}
.sister-links ul {
  text-align: center;
  display: flex;
  flex-wrap: wrap;
  margin: 10px auto;
  justify-content: center;
}
.sister-links li {
  text-align: center;
  padding: 5px 1em;
  border-right: 1px solid #ccc;
}
.sister-links li:last-child {
  border-right:none;
}
</style>
<div id="sister-links" class="sister-links">
<h3>Euclid Media Group, LLC</h3>
<h4>Read Our Sister Publications </h4>
<ul>
<li>
<a href="https://www.clevescene.com/" rel="noreferrer" target="_blank" heap-ignore="true">
Cleveland Scene
</a>
</li>
<li>
<a href="https://www.citybeat.com/" rel="noreferrer" target="_blank" heap-ignore="true">
Cincinnati CityBeat
</a>
</li>
<li>
<a href="https://www.cltampa.com/" rel="noreferrer" target="_blank" heap-ignore="true">
Creative Loafing Tampa
</a>
</li>
<li>
<a href="https://www.metrotimes.com/" rel="noreferrer" target="_blank" heap-ignore="true">
Detroit Metro Times
</a>
</li>
<li>
<a href="https://www.leoweekly.com/" rel="noreferrer" target="_blank" heap-ignore="true">
Louisville LEO Weekly
</a>
</li>
<li>
<a href="https://www.orlandoweekly.com/" rel="noreferrer" target="_blank" heap-ignore="true">
Orlando Weekly
</a>
</li>
<li>
<a href="https://www.sacurrent.com/" rel="noreferrer" target="_blank" heap-ignore="true">
San Antonio Current
</a>
</li>
<li>
<a href="https://outinsa.com/" rel="noreferrer" target="_blank" heap-ignore="true">
Out in SA
</a>
</li>
<li>
<a href="https://outinstl.com/" rel="noreferrer" target="_blank" heap-ignore="true">
Out in STL
</a>
</li>
</ul>
<h4>Marketing Services</h4>
<p>
<a href="https://localculturecreative.com/" target="_blank" heap-ignore="true">
Local Culture Creative
</a>
</p>
</div>
<div id="footerCopyright">
<p>
&copy; 2022
<a href="/stlouis/ContactUs/Page">Riverfront Times</a>
<br><br>
Website powered by <a href="https://www.publishwithfoundation.com/" target="_blank">Foundation</a>
</p>
</div>
<script type="text/javascript">
  (function(e,t,o,n,p,r,i){e.visitorGlobalObjectAlias=n;e[e.visitorGlobalObjectAlias]=e[e.visitorGlobalObjectAlias]||function(){(e[e.visitorGlobalObjectAlias].q=e[e.visitorGlobalObjectAlias].q||[]).push(arguments)};e[e.visitorGlobalObjectAlias].l=(new Date).getTime();r=t.createElement("script");r.src=o;r.async=true;i=t.getElementsByTagName("script")[0];i.parentNode.insertBefore(r,i)})(window,document,"https://diffuser-cdn.app-us1.com/diffuser/diffuser.js","vgo");
  vgo('setAccount', '26668640');
  vgo('setTrackByDefault', true);

  vgo('process');
</script>
</div>
</div>
</div>

<div id="gridCloser">
<div id="AdReskin" class="Closer ContentDefault ">

<div id="div-gpt-ad-stl_reskin" style="" data-content-type="ad" data-slot="/43707298/STL_Reskin" data-output="asynchronous" data-width="" data-height="">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-stl_reskin');
                });
              </script>
</div>
</div>
</div>
</body>
</html>
